summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.22.90.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 521865f9f838..25f214549918 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1 +1,2 @@
DIST kwallet-pam-5.22.5.tar.xz 19960 BLAKE2B 978860fc113e2a02bd2543aa5147832050fb3b53a1916939cc21772e98a7a2e4d47892d514427f15a3fbff70a6eadcb98fdd934fb8d731992ff3fc8252c32f6b SHA512 230135ee7aadbbc9f08695afa87fd7d8f0e3dca5da40f94bea92ad83a8a2ccc86efb7d593730079a0affc91f28383d089a08fd2b4db57961ba7c5b3a009a6038
+DIST kwallet-pam-5.22.90.tar.xz 20116 BLAKE2B 9ad8a89f9ed9adbdb93532bf555d22789c67905dd8c8b985c03a1472d0343be9cc26a73eee3dba140a609b50ce1fac85debe8c8bc6a8faed34fd85024ff0ad0d SHA512 c773af7ac2ecfe3e78c6ca185684ef0f91de85b94d808e1c683600cecfa9385275472673daa82c5e8fcd8648f72e14f60491581d0025df834d60da6b24e4a95d
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.22.90.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.22.90.ebuild
new file mode 100644
index 000000000000..bc2a2dd88454
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.22.90.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.86.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}