summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.21.5.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 56e25a720f23..b3c7657fc165 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,2 +1,3 @@
DIST plasma-integration-5.20.5.tar.xz 59740 BLAKE2B 8c6e054db3047093556ac9549ebe28e6270001838f28eea92138f4acc02c79235f6c0ab8d82de764dae16efa81cc7ff7519736935bd77153612ee035f7abf337 SHA512 fa0806c756d394ab6f419252396f9d0a18652ed652adcb016dd2885f5238df843814f4661c63b193805834dcd43cb346f69ce33339520229c215d2ff45a24604
DIST plasma-integration-5.21.4.tar.xz 60944 BLAKE2B c8ba267425e6617f8ac2fc46b716cd196eaf44671c37d79fd41a17e84c704767df245cc31bb9241ce9750e877fccf5d2cffea007afe58af22ce04d373c77bbc4 SHA512 49f34235863e331cef273037472c9b95fe865b1f353c1c070c03e9e0cdfd8ad9c3b555eb5b12d62b31c12de58d645d221cc3f6930bcd0a886991a689bb6b87cf
+DIST plasma-integration-5.21.5.tar.xz 60972 BLAKE2B 2122d64fa98dcd65936b18a5f8c09939680566770468817ab14d9116c92d226f234811952fd61222ca5e000fe213735c0da26ce73f3c5587cff4d61fcf88d902 SHA512 655fee4335569325431e9fb7d368bdf82b43f1e0e0f727f95f11f481a81e8dbdcdc43470c1768b9ab5701159ffaf571b551edc57510a653e1c7fedc1c4216d92
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.21.5.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.21.5.ebuild
new file mode 100644
index 000000000000..02ab146b45d2
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.21.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.82.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# requires running kde environment
+RESTRICT+=" test"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[dbus]
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-plasma/breeze-${PVCUT}:5
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"