summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pngrewrite/pngrewrite-1.4.0.ebuild')
-rw-r--r--media-gfx/pngrewrite/pngrewrite-1.4.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-gfx/pngrewrite/pngrewrite-1.4.0.ebuild b/media-gfx/pngrewrite/pngrewrite-1.4.0.ebuild
new file mode 100644
index 000000000000..9e2ef9f32588
--- /dev/null
+++ b/media-gfx/pngrewrite/pngrewrite-1.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="A utility which reduces large palettes in PNG images"
+HOMEPAGE="http://entropymine.com/jason/pngrewrite/"
+SRC_URI="http://entropymine.com/jason/${PN}/${P}.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="media-libs/libpng"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}