summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pycam/pycam-0.6_pre20130416-r1.ebuild')
-rw-r--r--media-gfx/pycam/pycam-0.6_pre20130416-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/pycam/pycam-0.6_pre20130416-r1.ebuild b/media-gfx/pycam/pycam-0.6_pre20130416-r1.ebuild
new file mode 100644
index 000000000000..400327f65248
--- /dev/null
+++ b/media-gfx/pycam/pycam-0.6_pre20130416-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 python-r1
+
+DESCRIPTION="Open Source CAM - Toolpath Generation for 3-Axis CNC machining"
+HOMEPAGE="http://pycam.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~slis/${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+DEPEND="
+ dev-python/pygtk
+ dev-python/pygtkglext
+ dev-python/pyopengl
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix-export-toolpath.patch"
+ distutils-r1_src_prepare
+}