summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/qrencode/qrencode-4.0.2.ebuild')
-rw-r--r--media-gfx/qrencode/qrencode-4.0.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-gfx/qrencode/qrencode-4.0.2.ebuild b/media-gfx/qrencode/qrencode-4.0.2.ebuild
new file mode 100644
index 000000000000..a12c5fe02c0a
--- /dev/null
+++ b/media-gfx/qrencode/qrencode-4.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="C library for encoding data in a QR Code symbol"
+HOMEPAGE="https://fukuchi.org/works/qrencode/"
+SRC_URI="https://fukuchi.org/works/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0/4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="media-libs/libpng:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_with test tests)
+ # TODO: figure out how to make SDL check fail as the SDL test
+ # program is not useful
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ cd tests || die
+ ./test_basic.sh || die
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}