summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/chromaprint/chromaprint-1.2.ebuild')
-rw-r--r--media-libs/chromaprint/chromaprint-1.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/chromaprint/chromaprint-1.2.ebuild b/media-libs/chromaprint/chromaprint-1.2.ebuild
new file mode 100644
index 000000000000..670ff3859c7b
--- /dev/null
+++ b/media-libs/chromaprint/chromaprint-1.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="A client-side library that implements a custom algorithm for extracting fingerprints"
+HOMEPAGE="http://acoustid.org/chromaprint"
+SRC_URI="https://bitbucket.org/acoustid/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc ~ppc64 x86 ~amd64-fbsd"
+IUSE="libav test tools"
+
+# note: use ffmpeg or libav instead of fftw because it's recommended and required for tools
+RDEPEND="
+ libav? ( media-video/libav:0= )
+ !libav? ( media-video/ffmpeg:0= )
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/gtest
+ dev-libs/boost
+ )"
+
+DOCS="NEWS.txt README.md"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.1-gtest.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build tools EXAMPLES)
+ $(cmake-utils_use_build test TESTS)
+ -DWITH_AVFFT=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ emake check
+}
+
+src_install() {
+ cmake-utils_src_install
+}