summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libsndfile/libsndfile-9999.ebuild')
-rw-r--r--media-libs/libsndfile/libsndfile-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/media-libs/libsndfile/libsndfile-9999.ebuild b/media-libs/libsndfile/libsndfile-9999.ebuild
index fe3ad230a792..541b8501fc49 100644
--- a/media-libs/libsndfile/libsndfile-9999.ebuild
+++ b/media-libs/libsndfile/libsndfile-9999.ebuild
@@ -3,23 +3,23 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
if [[ ${PV} == *9999 ]]; then
inherit autotools git-r3
- EGIT_REPO_URI="https://github.com/erikd/libsndfile.git"
+ EGIT_REPO_URI="https://github.com/libsndfile/libsndfile.git"
else
- SRC_URI="https://github.com/erikd/libsndfile/releases/download/v${PV}/${P}.tar.bz2"
+ SRC_URI="https://github.com/libsndfile/libsndfile/releases/download/${PV}/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
fi
inherit python-any-r1 multilib-minimal
DESCRIPTION="C library for reading and writing files containing sampled sound"
-HOMEPAGE="http://www.mega-nerd.com/libsndfile"
+HOMEPAGE="http://libsndfile.github.io/libsndfile/"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="alsa minimal sqlite static-libs test"
+IUSE="alsa minimal sqlite test"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -57,8 +57,8 @@ src_prepare() {
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
--disable-octave \
+ --disable-static \
--disable-werror \
- $(use_enable static-libs static) \
$(use_enable !minimal external-libs) \
$(multilib_native_enable full-suite) \
$(multilib_native_use_enable alsa) \
@@ -69,6 +69,6 @@ multilib_src_configure() {
multilib_src_install_all() {
einstalldocs
- # package provides .pc files
- find "${D}" -name '*.la' -delete || die
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}