summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/kaudiocreator/kaudiocreator-1.3-r3.ebuild')
-rw-r--r--media-sound/kaudiocreator/kaudiocreator-1.3-r3.ebuild24
1 files changed, 21 insertions, 3 deletions
diff --git a/media-sound/kaudiocreator/kaudiocreator-1.3-r3.ebuild b/media-sound/kaudiocreator/kaudiocreator-1.3-r3.ebuild
index 355b11cf5bcb..dcb40b9acb75 100644
--- a/media-sound/kaudiocreator/kaudiocreator-1.3-r3.ebuild
+++ b/media-sound/kaudiocreator/kaudiocreator-1.3-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -9,7 +9,7 @@ pl pt_BR pt ro ru se sk sl sr@ijekavianlatin sr@ijekavian sr@Latn sr sv ta tg
th tr ug uk xh zh_CN zh_HK zh_TW"
inherit kde4-base
-DESCRIPTION="KDE CD ripper and audio encoder frontend"
+DESCRIPTION="CD ripper and audio encoder frontend based on KDE Frameworks"
HOMEPAGE="http://www.kde-apps.org/content/show.php?content=107645"
SRC_URI="http://www.kde-apps.org/CONTENT/content-files/107645-${P}.tar.bz2"
@@ -24,10 +24,28 @@ DEPEND="
media-libs/libdiscid
>=media-libs/taglib-1.5
"
-
RDEPEND="${DEPEND}
kde-frameworks/kdelibs:4[udev,udisks(+)]
$(add_kdeapps_dep audiocd-kio)
"
DOCS=( Changelog TODO )
+
+pkg_postinst() {
+ local stcnt=0
+
+ has_version media-libs/flac && stcnt=$((stcnt+1))
+ has_version media-sound/lame && stcnt=$((stcnt+1))
+ has_version media-sound/vorbis-tools && stcnt=$((stcnt+1))
+
+ if [[ ${stcnt} -lt 1 ]] ; then
+ ewarn "You you should emerge at least one of the following packages"
+ ewarn "for ${PN} to do anything useful."
+ fi
+ elog "Optional runtime dependencies:"
+ elog "FLAC - media-libs/flac"
+ elog "MP3 - media-sound/lame"
+ elog "OGG - media-sound/vorbis-tools"
+
+ kde4-base_pkg_postinst
+}