summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mps-youtube/mps-youtube-9999.ebuild')
-rw-r--r--media-sound/mps-youtube/mps-youtube-9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-sound/mps-youtube/mps-youtube-9999.ebuild b/media-sound/mps-youtube/mps-youtube-9999.ebuild
new file mode 100644
index 000000000000..b79a2339dbb1
--- /dev/null
+++ b/media-sound/mps-youtube/mps-youtube-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/mps-youtube/mps-youtube.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Terminal-based YouTube player and downloader"
+HOMEPAGE="https://github.com/mps-youtube/mps-youtube https://pypi.python.org/pypi/mps-youtube"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/pafy[${PYTHON_USEDEP}]
+ virtual/ffmpeg
+ || ( media-video/mplayer media-video/mpv )"