summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/smixer/smixer-1.0.4.ebuild')
-rw-r--r--media-sound/smixer/smixer-1.0.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/smixer/smixer-1.0.4.ebuild b/media-sound/smixer/smixer-1.0.4.ebuild
new file mode 100644
index 000000000000..25ff7d7de966
--- /dev/null
+++ b/media-sound/smixer/smixer-1.0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="command-line tool for setting and viewing mixer settings"
+HOMEPAGE="http://centerclick.org/programs/smixer"
+SRC_URI="http://centerclick.org/programs/${PN}/${PN}${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LFLAGS="${LDFLAGS}"
+}
+
+src_install () {
+ insinto /etc
+ doins smixer.conf
+ dobin smixer
+ doman man/smixer.1
+ dodoc README
+}