summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/xineadump')
-rw-r--r--media-sound/xineadump/Manifest1
-rw-r--r--media-sound/xineadump/files/xineadump-0.1-gcc-4.3.patch20
-rw-r--r--media-sound/xineadump/files/xineadump-0.1-gcc-4.4.patch11
-rw-r--r--media-sound/xineadump/metadata.xml8
-rw-r--r--media-sound/xineadump/xineadump-0.1-r1.ebuild31
5 files changed, 71 insertions, 0 deletions
diff --git a/media-sound/xineadump/Manifest b/media-sound/xineadump/Manifest
new file mode 100644
index 000000000000..fcc748869f42
--- /dev/null
+++ b/media-sound/xineadump/Manifest
@@ -0,0 +1 @@
+DIST xineadump-0.1.tar.bz2 233413 SHA256 a00a3377be2df8bcb2639f7e9d40faaf531362e67bd13130764042611a2067eb
diff --git a/media-sound/xineadump/files/xineadump-0.1-gcc-4.3.patch b/media-sound/xineadump/files/xineadump-0.1-gcc-4.3.patch
new file mode 100644
index 000000000000..ac3a879fa4fd
--- /dev/null
+++ b/media-sound/xineadump/files/xineadump-0.1-gcc-4.3.patch
@@ -0,0 +1,20 @@
+--- xineadump-orig/src/xineinput.cpp 2008-06-14 04:15:30.829493854 +0200
++++ xineadump/src/xineinput.cpp 2008-06-14 04:22:13.181493796 +0200
+@@ -19,6 +19,7 @@
+ ***************************************************************************/
+
+ #include "xineinput.h"
++#include <cstring>
+
+ static xine_t* xine;
+ static xine_audio_port_t* audio_port;
+--- xineadump-orig/src/zeroinput.cpp 2008-06-14 04:15:39.153496528 +0200
++++ xineadump/src/zeroinput.cpp 2008-06-14 04:21:54.993493742 +0200
+@@ -20,6 +20,7 @@
+
+ #include "zeroinput.h"
+ #include <math.h>
++#include <cstring>
+
+ ZeroInput::ZeroInput(
+ unsigned long timeLimitMS,
diff --git a/media-sound/xineadump/files/xineadump-0.1-gcc-4.4.patch b/media-sound/xineadump/files/xineadump-0.1-gcc-4.4.patch
new file mode 100644
index 000000000000..f8e1ca1ef848
--- /dev/null
+++ b/media-sound/xineadump/files/xineadump-0.1-gcc-4.4.patch
@@ -0,0 +1,11 @@
+diff -ur xineadump.orig/src/waveencoder.cpp xineadump/src/waveencoder.cpp
+--- xineadump.orig/src/waveencoder.cpp 2007-08-05 02:39:36.000000000 +0300
++++ xineadump/src/waveencoder.cpp 2009-07-05 18:57:47.000000000 +0300
+@@ -19,6 +19,7 @@
+ ***************************************************************************/
+
+ #include "waveencoder.h"
++#include <cstdio>
+
+ #define WAVE_HEADER_SIZE 44
+ #define PCM_BUFFER_SIZE 0x10000 // 64KB
diff --git a/media-sound/xineadump/metadata.xml b/media-sound/xineadump/metadata.xml
new file mode 100644
index 000000000000..b7522fc56f9f
--- /dev/null
+++ b/media-sound/xineadump/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">transkode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/xineadump/xineadump-0.1-r1.ebuild b/media-sound/xineadump/xineadump-0.1-r1.ebuild
new file mode 100644
index 000000000000..5a4383924c0a
--- /dev/null
+++ b/media-sound/xineadump/xineadump-0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Utility for Xine decoding support in transKode"
+HOMEPAGE="http://sourceforge.net/projects/transkode"
+SRC_URI="mirror://sourceforge/transkode/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="media-libs/xine-lib
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.3.patch \
+ "${FILESDIR}"/${P}-gcc-4.4.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS
+}