summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/maradns/Manifest1
-rw-r--r--net-dns/maradns/maradns-2.0.14.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/net-dns/maradns/Manifest b/net-dns/maradns/Manifest
index fa432eb341b7..221f300e61ac 100644
--- a/net-dns/maradns/Manifest
+++ b/net-dns/maradns/Manifest
@@ -1 +1,2 @@
DIST maradns-2.0.09.tar.bz2 1139409 SHA256 e1ee80836f0fbc47b9b94ec839e112ea19c40bed0b70d672d231849a4dea1083 SHA512 42bfcafaf4e465d8d566b4d9ea8383b5d0f553486b86dd807b35a07358987227e5dc8187de0e8192fba5b53098d61f91091cec112ef7cc80c5d5e73d8acff3bf WHIRLPOOL 6f3e55d8c6633a465c0e9de576921d833c67332cf0cbc8c01e7bc7d70c46102c32566d0ee867cdbf11c8b2b1d5cdc40d18ee4791bd0a4e045ad0e0bc590e61d6
+DIST maradns-2.0.14.tar.bz2 1156272 BLAKE2B 7e96d0769dd1df70316cc1bd79fb7e902c723f78db035fe721aaab0d6902958a40c2743374824ae024759164ad9cbda9a3c6ecaec7cc6bf3c5fa7b384101c16f SHA512 57527bba2f9801904f59cc7d9e56cbd7124635841ad8c91cbd3d1b8d58e7fe38d509e19f6ea53e2790777e054b68bb8df02bfa820ba7c9dbe65262e1993a2aa4
diff --git a/net-dns/maradns/maradns-2.0.14.ebuild b/net-dns/maradns/maradns-2.0.14.ebuild
new file mode 100644
index 000000000000..8d0ca3ee8416
--- /dev/null
+++ b/net-dns/maradns/maradns-2.0.14.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 systemd toolchain-funcs user
+
+DEADWOOD_VER="3.2.10"
+
+DESCRIPTION="A security-aware DNS server"
+HOMEPAGE="http://www.maradns.org/"
+SRC_URI="http://www.maradns.org/download/${PV%.*}/${PV}/${P}.tar.bz2"
+
+# The GPL-2 covers the init script, bug 426018.
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE="authonly examples ipv6"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+
+pkg_setup() {
+ ebegin "Creating group and users"
+ enewgroup maradns 99
+ enewuser duende 66 -1 -1 maradns
+ enewuser maradns 99 -1 -1 maradns
+ eend ${?}
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Use duende-ng.c.
+ cp tools/duende{,-ng}.c \
+ || die "failed to rename duende-ng.c"
+ # replace "make" by "$(MAKE)" to avoid GNU Make warning
+ sed -i 's/\ make\ /\ \$\(MAKE\)\ /g' build/Makefile.linux \
+ || die "can't patch build/Makefile.linux"
+
+ python_fix_shebang tools/bind2csv2.py
+}
+
+src_configure() {
+ tc-export CC
+ ./configure $(use ipv6 && echo "--ipv6") || die "Failed to configure ${PN}"
+}
+
+src_install() {
+ # Install the MaraDNS and Deadwood binaries
+ dosbin server/maradns
+ dosbin tcp/zoneserver
+ if ! use authonly; then
+ dosbin deadwood-${DEADWOOD_VER}/src/Deadwood
+ fi
+ dobin tcp/{getzone,fetchzone}
+ dobin tools/{askmara,askmara-tcp,duende,bind2csv2.py,csv1tocsv2.pl}
+
+ # MaraDNS docs, manpages, misc
+ dodoc doc/en/{QuickStart,README,*.txt,*.html}
+ dodoc -r doc/en/{text,webpage,tutorial}
+ dodoc maradns.gpg.key
+ if ! use authonly; then
+ docinto deadwood
+ dodoc deadwood-${DEADWOOD_VER}/doc/{*.txt,*.html,CHANGELOG,Deadwood-HOWTO}
+ dodoc -r deadwood-${DEADWOOD_VER}/doc/internals
+ fi
+
+ # Install examples (optional)
+ if use examples ; then
+ docinto examples
+ dodoc doc/en/examples/example_*
+ fi
+
+ # Install manpages
+ doman doc/en/man/*.[1-9]
+ if ! use authonly; then
+ doman deadwood-${DEADWOOD_VER}/doc/{Deadwood,Duende}.1
+ fi
+
+ # Example configurations.
+ insinto /etc/maradns
+ newins doc/en/examples/example_full_mararc mararc_full.dist
+ newins doc/en/examples/example_csv2 example_csv2.dist
+ if ! use authonly; then
+ newins deadwood-${DEADWOOD_VER}/doc/dwood3rc-all dwood3rc_all.dist
+ fi
+ keepdir /etc/maradns/logger
+
+ # Init scripts.
+ newinitd "${FILESDIR}"/maradns2 maradns
+ newinitd "${FILESDIR}"/zoneserver2 zoneserver
+ if ! use authonly; then
+ newinitd "${FILESDIR}"/deadwood deadwood
+ fi
+
+ # systemd unit
+ # please keep paths in sync!
+ sed -e "s^@bindir@^${EPREFIX}/usr/sbin^" \
+ -e "s^@sysconfdir@^${EPREFIX}/etc/maradns^" \
+ "${FILESDIR}"/maradns.service.in > "${T}"/maradns.service \
+ || die "failed to create the maradns.service file (sed)"
+
+ systemd_dounit "${T}"/maradns.service
+}