summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/dshieldpy/dshieldpy-3.2-r1.ebuild')
-rw-r--r--net-firewall/dshieldpy/dshieldpy-3.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-firewall/dshieldpy/dshieldpy-3.2-r1.ebuild b/net-firewall/dshieldpy/dshieldpy-3.2-r1.ebuild
new file mode 100644
index 000000000000..8c3cc06c927f
--- /dev/null
+++ b/net-firewall/dshieldpy/dshieldpy-3.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+PYTHON_DEPEND="2"
+inherit python
+
+DESCRIPTION="Python script to submit firewall logs to dshield.org"
+HOMEPAGE="http://dshieldpy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dshieldpy/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+S=${WORKDIR}/DShield.py
+
+src_install() {
+ dodoc CHANGELOG README*
+ dobin dshield.py
+
+ insinto /etc
+ doins dshieldpy.conf
+ python_convert_shebangs 2 "${ED}"usr/bin/dshield.py
+}