summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/pglinux/Manifest1
-rw-r--r--net-firewall/pglinux/pglinux-2.3.1_p20171006.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/net-firewall/pglinux/Manifest b/net-firewall/pglinux/Manifest
index c9691e92c28d..fa229c952e0f 100644
--- a/net-firewall/pglinux/Manifest
+++ b/net-firewall/pglinux/Manifest
@@ -1 +1,2 @@
DIST pgl-2.3.1.tar.gz 605656 BLAKE2B 1fbce4b3c7d116915b303093ef18f434c8bb9dd23e1065d42dc573face9274c68321477529b536868eca9c03f23f3aad67f371960d7e547ae8c07fdee09f6d10 SHA512 f23d44ad6448814ba0a2c90292ff4a933d31fed942886d63c50bb62fb56e1af70df72e09070ad3cd27c878f322576326040c330fbdbda63128ad304375b02a1e
+DIST pglinux-2.3.1_p20171006.zip 340253 BLAKE2B a39ecad1290dd31b126ed58c22f2de1162a4081e07f576509b5d77adffeb4a74b5aeb489f8f63134b0fc37d174e61b6631bdb350c3277729456092ba0ae3c600 SHA512 ea30076d7a21fa71d5e352c479cb1a463c9f244d675f5c7f9d5d25a33b27f4c7f1a39d173f2fd156e3f2cb0652da0a06c078fc38972275073f38d48f207e42f3
diff --git a/net-firewall/pglinux/pglinux-2.3.1_p20171006.ebuild b/net-firewall/pglinux/pglinux-2.3.1_p20171006.ebuild
new file mode 100644
index 000000000000..2fabdd344bab
--- /dev/null
+++ b/net-firewall/pglinux/pglinux-2.3.1_p20171006.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT=9d91ab6a8e6bc2b41e985aa698eb5c1eb364fea8
+MY_PN="peerguardian"
+MY_P="${MY_PN}-${PV}"
+inherit autotools gnome2-utils linux-info systemd
+
+DESCRIPTION="Privacy oriented firewall application"
+HOMEPAGE="https://sourceforge.net/projects/peerguardian/"
+SRC_URI="https://sourceforge.net/code-snapshots/git/p/pe/peerguardian/code.git/peerguardian-code-${COMMIT}.zip -> ${P}.zip"
+
+LICENSE="GPL-3"
+KEYWORDS=""
+SLOT="0"
+IUSE="cron dbus logrotate networkmanager qt5 zlib"
+REQUIRED_USE="qt5? ( dbus )"
+
+COMMON_DEPEND="
+ net-libs/libnetfilter_queue
+ net-libs/libnfnetlink
+ dbus? ( sys-apps/dbus )
+ qt5? ( sys-auth/polkit-qt[qt5(+)]
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ || ( kde-plasma/kde-cli-tools[kdesu] x11-misc/ktsuss )
+ )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ sys-devel/libtool:2
+"
+RDEPEND="${COMMON_DEPEND}
+ net-firewall/iptables
+ sys-apps/sysvinit
+ cron? ( virtual/cron )
+ logrotate? ( app-admin/logrotate )
+ networkmanager? ( net-misc/networkmanager:= )
+"
+
+CONFIG_CHECK="~NETFILTER_NETLINK
+ ~NETFILTER_NETLINK_QUEUE
+ ~NETFILTER_XTABLES
+ ~NETFILTER_XT_TARGET_NFQUEUE
+ ~NETFILTER_XT_MATCH_IPRANGE
+ ~NETFILTER_XT_MARK
+ ~NETFILTER_XT_MATCH_MULTIPORT
+ ~NETFILTER_XT_MATCH_STATE
+ ~NF_CONNTRACK
+ ~NF_CONNTRACK_IPV4
+ ~NF_DEFRAG_IPV4
+ ~IP_NF_FILTER
+ ~IP_NF_IPTABLES
+ ~IP_NF_TARGET_REJECT"
+
+S="${WORKDIR}/${MY_PN}-code-${COMMIT}"
+
+src_prepare() {
+ default
+ sed -e 's:/sbin/runscript:/sbin/openrc-run:' \
+ -i pglcmd/init/pgl.gentoo.in || die "Failed to convert to openrc-run"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-lowmem
+ --with-iconsdir=/usr/share/icons/hicolor/128x128/apps
+ --with-gentoo-init
+ --localstatedir=/var
+ $(use_enable cron)
+ $(use_enable dbus)
+ $(use_enable logrotate)
+ $(use_enable networkmanager)
+ $(use_with qt5)
+ $(use_enable zlib)
+ --with-systemd="$(systemd_get_systemunitdir)"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/{lib,log,spool}/pgl
+ rm -rf "${ED%/}"/tmp || die
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "Optional dependencies:"
+ elog " app-arch/p7zip (needed for blocklists packed as .7z)"
+ elog " app-arch/unzip (needed for blocklists packed as .zip)"
+ elog " virtual/mta (needed to send informational (blocklist updates) and"
+ elog " warning mails (if pglcmd.wd detects a problem.))"
+
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}