summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/prosody')
-rw-r--r--net-im/prosody/Manifest3
-rw-r--r--net-im/prosody/prosody-0.12.1.ebuild164
-rw-r--r--net-im/prosody/prosody-0.12.4.ebuild (renamed from net-im/prosody/prosody-0.12.0.ebuild)2
3 files changed, 2 insertions, 167 deletions
diff --git a/net-im/prosody/Manifest b/net-im/prosody/Manifest
index a5cf62919db7..8454059a66ea 100644
--- a/net-im/prosody/Manifest
+++ b/net-im/prosody/Manifest
@@ -1,2 +1 @@
-DIST prosody-0.12.0.tar.gz 610330 BLAKE2B 14694ee95dc6eb6d053278a9d7718fd7487fe7ef862b4e2ee0d57f2b60cdeb22d1c74eac4a4df7447ea3e9ff57fb3734a9c9997f2767ed3aa04682f265b82185 SHA512 b7144a413a5bc72b1e677504d5ced6583c7399c8334b39b4c9157da60f951300832b34a1d47703a0b217caa4f1d3a0f52ab59cef08b27c6b43e876e1dffca3ce
-DIST prosody-0.12.1.tar.gz 611898 BLAKE2B 0b65ffbd6d4703f9e5fbac80e8887a4a41297afd22a776fb2eaa718b309f46c55a9d78f1d3ea97d4434c6ea2ebfe7a9051532ceda25ad78611769bd031894084 SHA512 705d2bcd38ffb19e90dab19992711aebf3d81f7bca7f9791ae5149510d465ec837ddf26a8c547eff2f2d131e5a694ddc3d0aac0b8921df65808192ae00527a85
+DIST prosody-0.12.4.tar.gz 616043 BLAKE2B 6bbe779424a6de6b5d266c3f6301282e010b96c9baca79d8dff46ab91365e6c5fdaa1b52c3caaaf33dad0990fa2c298f0447d37fcc018067f6efcc23d633b4fc SHA512 e035ec9af3831c596ababbc0320f352b7253d3ee968c9937998ffc255839173c9278912a0897fa9f0a0665bc43603f8570b5e15dfd1cba4571599e86a98d8cf4
diff --git a/net-im/prosody/prosody-0.12.1.ebuild b/net-im/prosody/prosody-0.12.1.ebuild
deleted file mode 100644
index e9cab9fb7d64..000000000000
--- a/net-im/prosody/prosody-0.12.1.ebuild
+++ /dev/null
@@ -1,164 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-LUA_REQ_USE="deprecated(+)"
-
-inherit lua-single systemd tmpfiles toolchain-funcs
-
-DESCRIPTION="Prosody is a modern XMPP communication server"
-HOMEPAGE="https://prosody.im/"
-SRC_URI="https://prosody.im/downloads/source/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="icu +idn +libevent ldap mysql postgres selinux +sqlite +ssl test +zlib"
-REQUIRED_USE="
- ^^ ( icu idn )
- ${LUA_REQUIRED_USE}
-"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- acct-group/prosody
- acct-user/prosody
- $(lua_gen_cond_dep 'dev-lua/luaexpat[${LUA_USEDEP}]')
- $(lua_gen_cond_dep 'dev-lua/luafilesystem[${LUA_USEDEP}]')
- dev-lua/luarocks[${LUA_SINGLE_USEDEP}]
- $(lua_gen_cond_dep 'dev-lua/luasocket[${LUA_USEDEP}]')
- $(lua_gen_cond_dep 'dev-lua/lua-unbound[${LUA_USEDEP}]')
- $(lua_gen_cond_dep 'dev-lua/readline[${LUA_USEDEP}]')
- icu? ( dev-libs/icu:= )
- idn? ( net-dns/libidn:= )
- ldap? ( $(lua_gen_cond_dep 'dev-lua/lualdap[${LUA_USEDEP}]') )
- libevent? ( $(lua_gen_cond_dep 'dev-lua/luaevent[${LUA_USEDEP}]') )
- dev-libs/openssl:0=
- lua_single_target_lua5-1? ( $(lua_gen_cond_dep 'dev-lua/lua-bit32[lua_targets_lua5-1(-)]') )
- mysql? ( $(lua_gen_cond_dep 'dev-lua/luadbi[mysql,${LUA_USEDEP}]') )
- postgres? ( $(lua_gen_cond_dep 'dev-lua/luadbi[postgres,${LUA_USEDEP}]') )
- sqlite? ( $(lua_gen_cond_dep 'dev-lua/luadbi[sqlite,${LUA_USEDEP}]') )
- ssl? ( $(lua_gen_cond_dep 'dev-lua/luasec[${LUA_USEDEP}]') )
- zlib? ( $(lua_gen_cond_dep 'dev-lua/lua-zlib[${LUA_USEDEP}]') )
- ${LUA_DEPS}
-"
-
-RDEPEND="
- ${DEPEND}
- selinux? ( sec-policy/selinux-jabber )
-"
-
-BDEPEND="
- virtual/pkgconfig
- test? ( $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]') )
-"
-
-PATCHES=( "${FILESDIR}/${PN}-0.12.0-gentoo.patch" )
-
-src_prepare() {
- default
-
- # Set correct plugin path for optional net-im/prosody-modules package
- sed -e "s/GENTOO_LIBDIR/$(get_libdir)/g" -i prosody.cfg.lua.dist || die
-}
-
-src_configure() {
- local myeconfargs=(
- --add-cflags="${CFLAGS}"
- --add-ldflags="${LDFLAGS}"
- --c-compiler="$(tc-getCC)"
- --datadir="${EPREFIX}/var/lib/prosody"
- --idn-library="$(usex idn 'idn' 'icu')"
- --libdir="${EPREFIX}/usr/$(get_libdir)"
- --linker="$(tc-getCC)"
- --lua-version="$(usex lua_single_target_luajit '5.1' $(ver_cut 1-2 $(lua_get_version)))"
- --no-example-certs
- --ostype="linux"
- --prefix="${EPREFIX}/usr"
- --runwith="${ELUA}"
- --sysconfdir="${EPREFIX}/etc/prosody"
- --with-lua-include="${EPREFIX}/$(lua_get_include_dir)"
- --with-lua-lib="${EPREFIX}/$(lua_get_cmod_dir)"
- )
-
- # Since the configure script is handcrafted,
- # and yells at unknown options, do not use 'econf'.
- ./configure "${myeconfargs[@]}" || die
-
- rm makefile || die
- mv GNUmakefile Makefile || die
-}
-
-src_install() {
- default
-
- keepdir /var/lib/prosody
-
- newinitd "${FILESDIR}"/prosody.initd-r6 prosody
- systemd_newunit "${FILESDIR}"/prosody.service-r3 prosody.service
-
- newtmpfiles "${FILESDIR}"/prosody.tmpfilesd-r2 prosody.conf
-}
-
-pkg_postinst() {
- local migrate_to_prosody_user="false"
- tmpfiles_process prosody.conf
-
- if [[ ${REPLACING_VERSIONS} ]]; then
- for v in ${REPLACING_VERSIONS}; do
- if ver_test "${v}" -lt 0.12.0; then
- migrate_to_prosody_user="true"
- break
- fi
- done
- fi
-
- # Sarting with >=0.12.0, the prosody configuration is now in
- # /etc/prosody and no longer in /etc/jabber.
- # See if we need to migrate the configuration. Furthermore,
- # prosody no longer runs under the, shared via net-im/jabber-base,
- # 'jabber' use, but under its own user.
- # This increase isolation and hence robustness and security.
- if ${migrate_to_prosody_user}; then
- local -A dirs_to_migrate=(
- [/etc/jabber]=/etc/prosody
- [/var/log/jabber]=/var/log/prosody
- [/var/spool/jabber]=/var/lib/prosody
- )
-
- for src_dir in "${!dirs_to_migrate[@]}"; do
- local eroot_src_dir="${EROOT}/${src_dir}"
- local eroot_dst_dir="${EROOT}/${dirs_to_migrate[${src_dir}]}"
-
- cp -r "${eroot_src_dir}"/. "${eroot_dst_dir}" || die "Could not copy ${eroot_src_dir} to ${eroot_dst_dir}"
-
- if [[ -f "${eroot_dst_dir}"/.keep_net-im_jabber-base-0 ]]; then
- rm "${eroot_dst_dir}"/.keep_net-im_jabber-base-0 || die
- fi
-
- if ! use prefix; then
- chown --recursive prosody:prosody "${eroot_dst_dir}" || die
- fi
- done
-
- # Update configuration file to match new pathes and permissions
- local mysedargs=(
- -e "'s#/etc/jabber#/etc/prosody#g'"
- -e "'s#/run/jabber#/run/prosody#g'"
- -e "'s#/var/log/jabber#/var/log/prosody#g'"
- -e "'s/prosody_user.*/prosody_user = \"prosody\";/g'"
- -e "'s/prosody_group.*/prosody_group = \"prosody\";/g'"
- -i /etc/prosody/prosody.cfg.lua
- )
-
- eval sed "${mysedargs[@]}" || die
-
- ewarn "Newer versions of the prosody (Gentoo) package use ${EROOT}/etc/prosody"
- ewarn "(just as upstream) and *not* anymore ${EROOT}/etc/jabber."
- ewarn "The files from ${EROOT}/etc/jabber where copied to ${EROOT}/etc/prosody."
- ewarn "Also prosody's spool directory became ${EROOT}/var/lib/prosody (was ${EROOT}/var/spool/jabbber)."
- ewarn "Please check your configuration."
- fi
-}
diff --git a/net-im/prosody/prosody-0.12.0.ebuild b/net-im/prosody/prosody-0.12.4.ebuild
index 569a5077e12b..29ac71036832 100644
--- a/net-im/prosody/prosody-0.12.0.ebuild
+++ b/net-im/prosody/prosody-0.12.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8