summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/psi')
-rw-r--r--net-im/psi/Manifest2
-rw-r--r--net-im/psi/psi-1.2.ebuild13
-rw-r--r--net-im/psi/psi-1.3.ebuild125
-rw-r--r--net-im/psi/psi-9999.ebuild12
4 files changed, 150 insertions, 2 deletions
diff --git a/net-im/psi/Manifest b/net-im/psi/Manifest
index 4890f31fdc4e..3db78776f9ed 100644
--- a/net-im/psi/Manifest
+++ b/net-im/psi/Manifest
@@ -1,2 +1,4 @@
DIST psi-1.2.tar.xz 2138940 SHA256 16ce1b767d40453032cd5d9ad5a9d4c6dba43989acc9a09538da3f74b7c614f5 SHA512 a486f6ee910cc17157849a68aa724608ddbeed319511646f6973a0789da192ec0fed7899024ad169c5b0e604372025dad7a58bacd223723d35ea490ec7f00b20 WHIRLPOOL 2a0f37067a085b3ce93864905367fa56584666bee6697bdae8f4eedd74cdf15f7be9eee85ba23440cb39a11e384e5ce7218a408042203fe70b398058a69b7867
+DIST psi-1.3.tar.xz 2143076 SHA256 59debd16e61ab1d4ff88aca9f41b9caaaca8395f1576418fb99214d5e2c6fa8b SHA512 b1b0f8d0c8326d486cb908d7b7de8f48579a2775f4cad0721ebeb646abd35e890712df176dd8676bf6c6089db88e73cf1b0423bd7a0ea0054661bdcea89349fe WHIRLPOOL 4fdccf0b730e86a2b44c417ffdb83e0f5acab714e8a00badfed6b3095159a10c11bd8ab1a5656172e12920ff72e20178eca93257974d538152cff7cf49424e47
DIST psi-l10n-1.2.tar.gz 2992381 SHA256 8a16c2d67c0aafbaa296fe06cd6b7de5f32683487b10245b10e8baae63b8f789 SHA512 946b86d12e76fe9a44f1adc154140a02f3d575e57b5f67c8d95472241c6d4510d1b4be81d8914d5670b15ea8ad1b836aa63fc62c3de94e0091b39e2fb234a130 WHIRLPOOL 6cd52e0dcd76f7df3137055de9d9e4518b1adfb8d6f03e9af59e0a49b01933c400d15671b252ea529543eab8f14aae34be8432c43bb28d9233f57833c0517718
+DIST psi-l10n-1.3.tar.gz 2991441 SHA256 122fb6e45e511fe96d8a84beb86e8e6fcb11500f468f9e97b52fddf193041378 SHA512 22885352b5f443ff0719ae4e861ce5626e779ec231ac13b5cd48a7c57065289c6c5504ae6d1f5782ad05b3d27a477fd52e729cfcd1c774786872d8a79cf55090 WHIRLPOOL 6aa0b6bbba0feceda1ca38bcff0166d3e6e0ed2b81bfd15bdfeabfac29411f114fbc7a6c27650a7e00f5b89bd53ef47763fd7013cd3cd9233a01612181e7b4c8
diff --git a/net-im/psi/psi-1.2.ebuild b/net-im/psi/psi-1.2.ebuild
index 322c0c6e2842..92f7233fa5a6 100644
--- a/net-im/psi/psi-1.2.ebuild
+++ b/net-im/psi/psi-1.2.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="be bg ca cs de en eo es et fa fi fr he hu it ja kk mk nl pl pt pt_BR ru sk sl sr@latin sv sw uk ur_PK vi zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit l10n qmake-utils
+inherit l10n qmake-utils xdg-utils
DESCRIPTION="Qt XMPP client"
HOMEPAGE="http://psi-im.org/"
@@ -113,3 +113,14 @@ src_install() {
}
l10n_for_each_locale_do install_locale
}
+
+pkg_postinst()
+{
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/net-im/psi/psi-1.3.ebuild b/net-im/psi/psi-1.3.ebuild
new file mode 100644
index 000000000000..3d47e6fece4d
--- /dev/null
+++ b/net-im/psi/psi-1.3.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLOCALES="be bg ca cs de en eo es et fa fi fr he hu it ja kk mk nl pl pt pt_BR ru sk sl sr@latin sv sw uk ur_PK vi zh_CN zh_TW"
+PLOCALE_BACKUP="en"
+
+inherit l10n qmake-utils xdg-utils
+
+DESCRIPTION="Qt XMPP client"
+HOMEPAGE="http://psi-im.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz
+ https://github.com/psi-im/psi-l10n/archive/${PV}.tar.gz -> psi-l10n-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aspell crypt dbus debug doc enchant +hunspell ssl webengine webkit whiteboarding xscreensaver"
+
+# qconf generates not quite compatible configure scripts
+QA_CONFIGURE_OPTIONS=".*"
+
+REQUIRED_USE="
+ ?? ( aspell enchant hunspell )
+ webengine? ( !webkit )
+"
+
+RDEPEND="
+ app-crypt/qca:2[qt5]
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ net-dns/libidn
+ sys-libs/zlib[minizip]
+ x11-libs/libX11
+ x11-libs/libxcb
+ aspell? ( app-text/aspell )
+ dbus? ( dev-qt/qtdbus:5 )
+ enchant? ( >=app-text/enchant-1.3.0 )
+ hunspell? ( app-text/hunspell:= )
+ webengine? (
+ >=dev-qt/qtwebchannel-5.7:5
+ >=dev-qt/qtwebengine-5.7:5[widgets]
+ )
+ webkit? ( dev-qt/qtwebkit:5 )
+ whiteboarding? ( dev-qt/qtsvg:5 )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+PDEPEND="
+ crypt? ( app-crypt/qca[gpg] )
+ ssl? ( app-crypt/qca:2[ssl] )
+"
+
+RESTRICT="test"
+
+src_configure() {
+ CONF=(
+ --no-separate-debug-info
+ --qtdir="$(qt5_get_bindir)/.."
+ $(use_enable aspell)
+ $(use_enable dbus qdbus)
+ $(use_enable enchant)
+ $(use_enable hunspell)
+ $(use_enable xscreensaver xss)
+ $(use_enable whiteboarding)
+ )
+
+ use debug && CONF+=("--debug")
+ use webengine && CONF+=("--enable-webkit" "--with-webkit=qtwebengine")
+ use webkit && CONF+=("--enable-webkit" "--with-webkit=qtwebkit")
+
+ econf "${CONF[@]}"
+
+ eqmake5 psi.pro
+}
+
+src_compile() {
+ emake
+ use doc && emake -C doc api_public
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+
+ # this way the docs will be installed in the standard gentoo dir
+ rm "${ED}"/usr/share/psi/{COPYING,README} || die "Installed file set seems to be changed by upstream"
+ newdoc iconsets/roster/README README.roster
+ newdoc iconsets/system/README README.system
+ newdoc certs/README README.certs
+ dodoc README
+
+ use doc && HTML_DOCS=( doc/api/. )
+ einstalldocs
+
+ # install translations
+ local mylrelease="$(qt5_get_bindir)"/lrelease
+ cd "${WORKDIR}/psi-l10n-${PV}" || die
+ insinto /usr/share/psi
+ install_locale() {
+ "${mylrelease}" "translations/${PN}_${1}.ts" || die "lrelease ${1} failed"
+ doins "translations/${PN}_${1}.qm"
+ }
+ l10n_for_each_locale_do install_locale
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/net-im/psi/psi-9999.ebuild b/net-im/psi/psi-9999.ebuild
index 56868b48352b..20f9be17efad 100644
--- a/net-im/psi/psi-9999.ebuild
+++ b/net-im/psi/psi-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="be bg ca cs de en eo es et fa fi fr he hu it ja kk mk nl pl pt pt_BR ru sk sl sr@latin sv sw uk ur_PK vi zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit l10n git-r3 qmake-utils
+inherit l10n git-r3 qmake-utils xdg-utils
DESCRIPTION="Qt XMPP client"
HOMEPAGE="http://psi-im.org/"
@@ -187,3 +187,13 @@ src_install() {
}
l10n_for_each_locale_do install_locale
}
+
+pkg_postinst(){
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}