summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/qutim')
-rw-r--r--net-im/qutim/Manifest1
-rw-r--r--net-im/qutim/files/qutim-0.3.1-cmake-2.8.12-kde-build.patch25
-rw-r--r--net-im/qutim/files/qutim-0.3.2-astral-migrate-qt-telepaphy.patch151
-rw-r--r--net-im/qutim/metadata.xml40
-rw-r--r--net-im/qutim/qutim-0.3.2.ebuild187
5 files changed, 404 insertions, 0 deletions
diff --git a/net-im/qutim/Manifest b/net-im/qutim/Manifest
new file mode 100644
index 000000000000..932c79fdbaf4
--- /dev/null
+++ b/net-im/qutim/Manifest
@@ -0,0 +1 @@
+DIST qutim-0.3.2.tar.xz 10232436 SHA256 326bd4048cdee2913b6a01900d15736c54b431b4ec1a11c88e567920c2948849 SHA512 0767552e31d6e999f6622f14a48e2da7f4497b4a958550189dce38709689cb5f12e9b91a55b5d94d1a24f3e8149cf8453dea56b7e5a8c1758a6579c4142f01cb WHIRLPOOL dac2bb0c43e4bc195c2374aa885ae8174317eccb8e02d011902f4416b3808bf598507e1c74668f1ff04a53bd828d8695c93cc83e04342fdb92688b44236eb2a5
diff --git a/net-im/qutim/files/qutim-0.3.1-cmake-2.8.12-kde-build.patch b/net-im/qutim/files/qutim-0.3.1-cmake-2.8.12-kde-build.patch
new file mode 100644
index 000000000000..f32379662417
--- /dev/null
+++ b/net-im/qutim/files/qutim-0.3.1-cmake-2.8.12-kde-build.patch
@@ -0,0 +1,25 @@
+From 984d4af9568de9c54a44e4cf96cca76e0cea256a Mon Sep 17 00:00:00 2001
+From: Ruslan Nigmatullin <euroelessar@yandex.ru>
+Date: Mon, 24 Feb 2014 18:09:20 +0300
+Subject: [PATCH 2/2] Fixed compilation with the newest cmake
+
+---
+ plugins/kdeintegration/CMakeLists.txt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/plugins/kdeintegration/CMakeLists.txt b/plugins/kdeintegration/CMakeLists.txt
+index 6f1a9f8..805ad80 100644
+--- a/plugins/kdeintegration/CMakeLists.txt
++++ b/plugins/kdeintegration/CMakeLists.txt
+@@ -8,6 +8,8 @@ endif()
+
+ include(KDE4Defaults)
+
++set(CMAKE_AUTOMOC true)
++
+ add_definitions( ${KDE4_DEFINITIONS} )
+
+ qutim_add_plugin(kdeintegration
+--
+2.0.4
+
diff --git a/net-im/qutim/files/qutim-0.3.2-astral-migrate-qt-telepaphy.patch b/net-im/qutim/files/qutim-0.3.2-astral-migrate-qt-telepaphy.patch
new file mode 100644
index 000000000000..dd1aba82891c
--- /dev/null
+++ b/net-im/qutim/files/qutim-0.3.2-astral-migrate-qt-telepaphy.patch
@@ -0,0 +1,151 @@
+From bb8654db870d983d5b6558d9f16b22f443315eaf Mon Sep 17 00:00:00 2001
+From: Alexander Golubev <fatzer2@gmail.com>
+Date: Mon, 3 Nov 2014 16:30:27 +0300
+Subject: [PATCH 3/3] protocol/astral: migrate to qt-telepaphy API v0.9
+
+---
+ protocols/astral/src/astralaccount.cpp | 12 ++++++------
+ protocols/astral/src/astralaccount.h | 14 +++++++-------
+ protocols/astral/src/astralcontact.h | 6 +++---
+ protocols/astral/src/astralplugin.cpp | 6 +++---
+ protocols/astral/src/astralroster.cpp | 14 +++++++-------
+ protocols/astral/src/astralsession.h | 4 ++--
+ 6 files changed, 28 insertions(+), 28 deletions(-)
+
+diff --git a/protocols/astral/src/astralaccount.cpp b/protocols/astral/src/astralaccount.cpp
+index 1d51707..e9bf729 100644
+--- a/protocols/astral/src/astralaccount.cpp
++++ b/protocols/astral/src/astralaccount.cpp
+@@ -26,9 +26,9 @@
+ #include "astralprotocol.h"
+ #include "astralroster.h"
+ #include "astralsessionmanager.h"
+-#include <TelepathyQt4/Account>
+-#include <TelepathyQt4/AccountManager>
+-#include <TelepathyQt4/PendingChannel>
++#include <TelepathyQt/Account>
++#include <TelepathyQt/AccountManager>
++#include <TelepathyQt/PendingChannel>
+ #include <QDebug>
+
+ struct AstralAccountPrivate
+@@ -146,14 +146,14 @@ void AstralAccount::onNewChannels(const Tp::ChannelDetailsList &channels)
+ qDebug() << "AstralAccount::onNewChannels";
+ foreach (const Tp::ChannelDetails &details, channels)
+ {
+- QString channelType = details.properties.value(QLatin1String(TELEPATHY_INTERFACE_CHANNEL ".ChannelType")).toString();
+- bool requested = details.properties.value(QLatin1String(TELEPATHY_INTERFACE_CHANNEL ".Requested")).toBool();
++ QString channelType = details.properties.value(TP_QT_IFACE_CHANNEL + QLatin1String(".ChannelType")).toString();
++ bool requested = details.properties.value(TP_QT_IFACE_CHANNEL + QLatin1String(".Requested")).toBool();
+ qDebug() << " channelType:" << channelType;
+ qDebug() << " requested :" << requested;
+ qDebug() << " channelPath:" << details.channel.path();
+ qDebug() << " properties :" << details.properties;
+
+- if (channelType == TELEPATHY_INTERFACE_CHANNEL_TYPE_TEXT && !requested)
++ if (channelType == TP_QT_IFACE_CHANNEL_TYPE_TEXT && !requested)
+ {
+ TextChannelPtr channel = TextChannel::create(p->conn,
+ details.channel.path(),
+diff --git a/protocols/astral/src/astralaccount.h b/protocols/astral/src/astralaccount.h
+index 2781fb9..6e4378d 100644
+--- a/protocols/astral/src/astralaccount.h
++++ b/protocols/astral/src/astralaccount.h
+@@ -26,13 +26,13 @@
+ #define ASTRALACCOUNT_H
+
+ #include <qutim/account.h>
+-#include <TelepathyQt4/ConnectionManager>
+-#include <TelepathyQt4/Connection>
+-#include <TelepathyQt4/TextChannel>
+-#include <TelepathyQt4/AccountManager>
+-#include <TelepathyQt4/PendingConnection>
+-#include <TelepathyQt4/PendingOperation>
+-#include <TelepathyQt4/PendingReady>
++#include <TelepathyQt/ConnectionManager>
++#include <TelepathyQt/Connection>
++#include <TelepathyQt/TextChannel>
++#include <TelepathyQt/AccountManager>
++#include <TelepathyQt/PendingConnection>
++#include <TelepathyQt/PendingOperation>
++#include <TelepathyQt/PendingReady>
+
+ #include "astralroster.h"
+
+diff --git a/protocols/astral/src/astralcontact.h b/protocols/astral/src/astralcontact.h
+index ce0e9dd..5adfb07 100644
+--- a/protocols/astral/src/astralcontact.h
++++ b/protocols/astral/src/astralcontact.h
+@@ -26,9 +26,9 @@
+ #define ASTRALCONTACT_H
+
+ #include <qutim/contact.h>
+-#include <TelepathyQt4/Types>
+-#include <TelepathyQt4/Contact>
+-#include <TelepathyQt4/Connection>
++#include <TelepathyQt/Types>
++#include <TelepathyQt/Contact>
++#include <TelepathyQt/Connection>
+
+ using namespace Tp;
+ using namespace qutim_sdk_0_3;
+diff --git a/protocols/astral/src/astralplugin.cpp b/protocols/astral/src/astralplugin.cpp
+index e907866..d79642e 100644
+--- a/protocols/astral/src/astralplugin.cpp
++++ b/protocols/astral/src/astralplugin.cpp
+@@ -24,9 +24,9 @@
+ ****************************************************************************/
+ #include "astralplugin.h"
+ #include <QtCore/QtDebug>
+-#include <TelepathyQt4/Debug>
+-#include <TelepathyQt4/Constants>
+-#include <TelepathyQt4/Types>
++#include <TelepathyQt/Debug>
++#include <TelepathyQt/Constants>
++#include <TelepathyQt/Types>
+ //#include <TelepathyQt4/ConnectionInterfaceAvatarsInterface>
+
+ AstralPlugin::AstralPlugin()
+diff --git a/protocols/astral/src/astralroster.cpp b/protocols/astral/src/astralroster.cpp
+index 9eb209f..588cc55 100644
+--- a/protocols/astral/src/astralroster.cpp
++++ b/protocols/astral/src/astralroster.cpp
+@@ -24,13 +24,13 @@
+ ****************************************************************************/
+ #include "astralroster.h"
+ #include "astralaccount.h"
+-#include <TelepathyQt4/Types>
+-#include <TelepathyQt4/Contact>
+-#include <TelepathyQt4/ContactManager>
+-#include <TelepathyQt4/PendingConnection>
+-#include <TelepathyQt4/PendingContacts>
+-#include <TelepathyQt4/PendingOperation>
+-#include <TelepathyQt4/PendingReady>
++#include <TelepathyQt/Types>
++#include <TelepathyQt/Contact>
++#include <TelepathyQt/ContactManager>
++#include <TelepathyQt/PendingConnection>
++#include <TelepathyQt/PendingContacts>
++#include <TelepathyQt/PendingOperation>
++#include <TelepathyQt/PendingReady>
+
+ struct AstralRosterPrivate
+ {
+diff --git a/protocols/astral/src/astralsession.h b/protocols/astral/src/astralsession.h
+index fa78e45..a5dd1c3 100644
+--- a/protocols/astral/src/astralsession.h
++++ b/protocols/astral/src/astralsession.h
+@@ -26,8 +26,8 @@
+ #define ASTRALSESSION_H
+
+ #include <qutim/chatunit.h>
+-#include <TelepathyQt4/TextChannel>
+-#include <TelepathyQt4/Message>
++#include <TelepathyQt/TextChannel>
++#include <TelepathyQt/Message>
+
+ using namespace qutim_sdk_0_3;
+ using namespace Tp;
+--
+2.0.4
+
diff --git a/net-im/qutim/metadata.xml b/net-im/qutim/metadata.xml
new file mode 100644
index 000000000000..8862591a628c
--- /dev/null
+++ b/net-im/qutim/metadata.xml
@@ -0,0 +1,40 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>fatzer2@gmail.com</email>
+ <name>Alexander Golubev</name>
+ <description>Proxied maintainer. Assign bugs on him</description>
+</maintainer>
+<upstream>
+ <maintainer>
+ <email>euroelessar@yandex.ru</email>
+ <name>Ruslan Nigmatullin</name>
+ </maintainer>
+ <bugs-to>https://github.com/euroelessar/qutim/issues</bugs-to>
+</upstream>
+<use>
+ <flag name="aspell">Enable spellchecking using <pkg>app-text/aspell</pkg></flag>
+ <flag name="awn">Enable integration with <pkg>gnome-extra/avant-window-navigator</pkg></flag>
+ <flag name="crypt">Enable AES crypto plugin</flag>
+ <flag name="histman">Enable history importer plugin</flag>
+ <flag name="hunspell">Enable spellchecking using <pkg>app-text/hunspell</pkg></flag>
+ <flag name="irc">Enable IRC protocol support</flag>
+ <flag name="mrim">Enable mail.ru protocol support</flag>
+ <flag name="otr">Enable plugin for encrypted conversations (Off-The-Record messaging)</flag>
+ <flag name="phonon">Add sound support via <pkg>media-libs/phonon</pkg> or <pkg>dev-qt/qtphonon</pkg></flag>
+ <flag name="purple">Enable libpurple-based protocol support</flag>
+ <flag name="qml">Enable QtQuick-based chat plugin</flag>
+ <flag name="sdl">Add sound support via <pkg>media-libs/sdl-mixer</pkg></flag>
+ <flag name="vkontakte">Enable vkontakte protocol support</flag>
+ <flag name="webkit">Enable Adium-like WebView plugin</flag>
+ <flag name="xscreensaver">Use X screensaver protocol extension to monitor idle/active status based on mouse/keyboard events</flag>
+ <flag name="tools">Enable some extra tools for qt developers</flag>
+ <flag name="telepathy">Enable to connect various IMs through <pkg>net-im/telepathy-*</pkg></flag>
+ <flag name="antiboss">Enable support for the antiboss plugin</flag>
+ <flag name="espionage">!!Not recomended, contains privacy risk!! Enable control plugin that controls user by sending messages and roster to remote server</flag>
+ <flag name="mobility">Enable several mobility related plugins like vibro notification</flag>
+ <flag name="plugman">Enable downloadable content management with <pkg>dev-libs/libattica</pkg></flag>
+</use>
+</pkgmetadata>
diff --git a/net-im/qutim/qutim-0.3.2.ebuild b/net-im/qutim/qutim-0.3.2.ebuild
new file mode 100644
index 000000000000..ff2e14f26b59
--- /dev/null
+++ b/net-im/qutim/qutim-0.3.2.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+LANGS="ar be bg cs de en_GB es fr he nds ru sk uk uz zh_CN"
+
+inherit qt4-r2 cmake-utils
+
+DESCRIPTION="Qt4-based multi-protocol instant messenger"
+HOMEPAGE="http://www.qutim.org"
+SRC_URI="http://www.qutim.org/dwnl/68/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# general USE
+IUSE="doc +sound tools"
+# protocol uses
+IUSE="$IUSE telepathy irc xmpp jingle mrim oscar purple vkontakte"
+# plugins
+IUSE="$IUSE antiboss aspell ayatana awn crypt dbus debug -espionage histman hunspell
+ kde mobility otr plugman phonon purple qml sdl +ssl +xscreensaver webkit"
+
+REQUIRED_USE="
+ oscar? ( ssl )
+ jingle? ( xmpp )
+ qml? ( webkit )
+"
+
+# Minimum Qt version required
+QT_PV="4.7.0:4"
+
+CDEPEND="
+ x11-libs/libqxt
+ >=dev-qt/qtcore-${QT_PV}[ssl?]
+ >=dev-qt/qtgui-${QT_PV}
+ >=dev-qt/qtscript-${QT_PV}
+ >=dev-qt/qtdeclarative-${QT_PV}
+
+ telepathy? ( >=net-libs/telepathy-qt-0.3 )
+ xmpp? (
+ app-crypt/qca:2[qt4(+)]
+ >=net-libs/jreen-1.2.0
+ )
+ jingle? ( dev-qt/qt-mobility[multimedia] )
+ oscar? ( app-crypt/qca:2[qt4(+)] )
+ purple? ( net-im/pidgin )
+ vkontakte? ( >=dev-qt/qtwebkit-${QT_PV} )
+
+ aspell? ( app-text/aspell )
+ awn? ( >=dev-qt/qtdbus-${QT_PV} )
+ crypt? ( app-crypt/qca:2[qt4(+)] )
+ dbus? ( >=dev-qt/qtdbus-${QT_PV} )
+ espionage? ( app-crypt/qca:2[qt4(+)] )
+ histman? ( >=dev-qt/qtsql-${QT_PV} )
+ ayatana? ( >=dev-libs/libindicate-qt-0.2.2 )
+ hunspell? ( app-text/hunspell )
+ kde? ( kde-base/kdelibs:4 )
+ mobility? (
+ dev-qt/qt-mobility[multimedia,feedback]
+ >=dev-qt/qtbearer-${QT_PV}
+ )
+ otr? (
+ >=net-libs/libotr-3.2.0
+ <net-libs/libotr-4.0.0
+ )
+ phonon? (
+ kde? ( media-libs/phonon[qt4] )
+ !kde? ( || ( >=dev-qt/qtphonon-${QT_PV} media-libs/phonon[qt4] ) )
+ )
+ plugman? (
+ dev-libs/libattica
+ app-arch/libarchive
+ )
+ qml? (
+ >=dev-qt/qtopengl-${QT_PV}
+ )
+ sdl? ( media-libs/sdl-mixer )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ webkit? ( >=dev-qt/qtwebkit-${QT_PV} )
+"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ kde? ( dev-util/automoc )
+"
+RDEPEND="${CDEPEND}
+ xmpp? ( app-crypt/qca:2[gpg] )
+ oscar? ( app-crypt/qca:2[openssl] )
+ kde-apps/oxygen-icons
+"
+
+DOCS=( AUTHORS INSTALL ChangeLog )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.1-cmake-2.8.12-kde-build.patch"
+ "${FILESDIR}/${P}-astral-migrate-qt-telepaphy.patch"
+)
+
+src_prepare() {
+ # fix automagic dep on libXScrnSaver
+ if ! use xscreensaver; then
+ sed -i -e '/XSS xscrnsaver/d' \
+ core/src/corelayers/idledetector/CMakeLists.txt || die
+ fi
+
+ # fix automagic dep on qt-mobility for jingle
+ if ! use jingle; then
+ sed -i -e '/find_package(QtMobility)/d' \
+ protocols/jabber/CMakeLists.txt || die
+ fi
+
+ # remove unwanted translations
+ local lang
+ for lang in ${LANGS}; do
+ use linguas_${lang} || rm -f translations/modules/*/${lang}.{po,ts}
+ done
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSYSTEM_JREEN=ON
+ $(cmake-utils_use_with doc DOXYGEN)
+ $(cmake-utils_use doc QUTIM_GENERATE_DOCS)
+ $(cmake-utils_use sound QUTIM_INSTALL_SOUND_THEME )
+ $(cmake-utils_use tools QUTIM_DEVELOPER_BUILD )
+
+ # protocols
+ $(cmake-utils_use telepathy ASTRAL )
+ $(cmake-utils_use irc )
+ $(cmake-utils_use xmpp JABBER )
+ $(cmake-utils_use mrim )
+ $(cmake-utils_use oscar )
+ $(cmake-utils_use purple QUETZAL )
+ $(cmake-utils_use vkontakte )
+
+ # plugins
+ $(cmake-utils_use webkit ADIUMWEBVIEW )
+ $(cmake-utils_use crypt AESCRYPTO )
+ $(cmake-utils_use antiboss ANTIBOSS )
+ $(cmake-utils_use aspell ASPELLER )
+ $(cmake-utils_use awn AWN )
+ $(cmake-utils_use espionage CONTROL ) # Also requires -DENABLE_ESPIONAGE=ON (see bellow)
+ $(cmake-utils_use dbus DBUSAPI )
+ $(cmake-utils_use dbus DBUSNOTIFICATIONS )
+ $(cmake-utils_use histman HISTMAN )
+ $(cmake-utils_use hunspell HUNSPELLER )
+ $(cmake-utils_use ayatana INDICATOR )
+ $(cmake-utils_use kde KDEINTEGRATION )
+ $(cmake-utils_use qml KINETICPOPUPS )
+ $(cmake-utils_use phonon PHONONSOUND )
+ $(cmake-utils_use plugman PLUGMAN )
+ $(cmake-utils_use debug LOGGER )
+ $(cmake-utils_use mobility MOBILITY )
+ $(cmake-utils_use dbus NOWPLAYING )
+ $(cmake-utils_use otr OFFTHERECORD )
+ $(cmake-utils_use qml QMLCHAT )
+ $(cmake-utils_use sdl SDLSOUND )
+ $(cmake-utils_use_enable espionage )
+ -DLINUXINTEGRATION=ON
+ -DDOCKTILE=OFF # QtDockTile currenly supports only unity;
+ # consider to make it optional if it also support kde or whatever
+ -DUPDATER=OFF
+ )
+ # NOTE: Integration plugins are autodisabled:
+ # symbianintegration macintegration maemo5integration haikunotifications meegointegration winintegration
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst () {
+ elog "Next qutim plugins are enabled by default:"
+ elog " antispam autopaster autoreply birthdayreminder blogimprover clconf"
+ elog " emoedit floaties formula highlighter imagepub massmessaging"
+ elog " oldcontactdelegate qrcicons screenshoter scriptapi unreadmessageskeeper urlpreview"
+ elog " weather webhistory yandexnarod"
+ elog "If you have strong reasons to make their build optional feel free to fill bugrepot."
+
+ if use espionage; then
+ ewarn "You have enabled the control (espionage) plugin. It may "
+ ewarn "deal negative security impact on the privacy of your client."
+ fi
+}