summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/kadu/Manifest1
-rw-r--r--net-im/kadu/files/kadu-2.1-port-to-QtQuick-2.3.patch150
-rw-r--r--net-im/kadu/kadu-0.12.3.ebuild2
-rw-r--r--net-im/kadu/kadu-2.1-r1.ebuild146
-rw-r--r--net-im/kadu/kadu-2.1.ebuild4
-rw-r--r--net-im/kadu/kadu-3.0.ebuild143
6 files changed, 443 insertions, 3 deletions
diff --git a/net-im/kadu/Manifest b/net-im/kadu/Manifest
index a50a33da2f97..45211ec46313 100644
--- a/net-im/kadu/Manifest
+++ b/net-im/kadu/Manifest
@@ -1,2 +1,3 @@
DIST kadu-0.12.3.tar.bz2 5106482 SHA256 d607bbd0d00b01bfb70dd15f15c8be4076896a935041651e67a3887ad12ab8a8 SHA512 0aeaec9ac3ce5a1860571721e307a8d5e6657a30780125e21d153901ce5f2870ba3ea6ebc272bbb6f35a56ed9a24127abfc8f25b9eb88d01ecf9c931fa5c851c WHIRLPOOL 0a2b1b9684577d95027b9107fc51e8a8f290b7ed38a18bf282f9589eb3dd5ca7a9fa61b088e2fb2be8d4d16e6d4e72d766476e36f7d65cc55a2d5efae53bb8ca
DIST kadu-2.1.tar.bz2 6013519 SHA256 9f8092756d4a870c1ecb016c0cba2c833e1697b3eb7e9bf51813b1f0a541ffb8 SHA512 3f0e38aefbaf15f357ae8232b1364deb5954a2464895fafa0a324ad99c7d14c6ba7495bed51d628e04c30bbaaf8e49412c70bbbbf01a40f360406c1afba2384a WHIRLPOOL 10b214ca8d1964054918dc0e1b85bf1157d2496e3ad340958302083a0374ac4fb7b6ac96741637f3847ac06dd9c322b0e529f9c204b9ebc6658157f7b7c2b8a2
+DIST kadu-3.0.tar.bz2 8002501 SHA256 3f5c0a66a33d1244acd981aef5c268d94185956754ca62e0c4295f7b50700366 SHA512 bc01a2355a53827a9139e460316fcb7ef4bca598964caa11868fe2634140ab8499f7845f0dd64aff0fdc0ba52ee27349f32793a8e2ad9d97b17e6f9a36eddb83 WHIRLPOOL bd743cc4d99d5ebae95e7230dc132e0f246a0b94dd02caa4f5fa92bd8ef3ec40905812c3711c009f56b9e61779fbbb0ec47e5f9b278e90c3665c363e7f865326
diff --git a/net-im/kadu/files/kadu-2.1-port-to-QtQuick-2.3.patch b/net-im/kadu/files/kadu-2.1-port-to-QtQuick-2.3.patch
new file mode 100644
index 000000000000..cdfd549a3475
--- /dev/null
+++ b/net-im/kadu/files/kadu-2.1-port-to-QtQuick-2.3.patch
@@ -0,0 +1,150 @@
+From 6912d8fc02b5ff4d6675656d6c00506c48fdd940 Mon Sep 17 00:00:00 2001
+From: Rafał Przemysław Malinowski <rafal.przemyslaw.malinowski@gmail.com>
+Date: Sat, 21 Mar 2015 01:32:11 +0100
+Subject: [PATCH] gui: ported open chat with from qml to quick 2.3
+
+Signed-off-by: Rafał Przemysław Malinowski <rafal.przemyslaw.malinowski@gmail.com>
+---
+ cmake/KaduMacros.cmake | 2 +-
+ kadu-core/CMakeLists.txt | 2 +-
+ kadu-core/gui/windows/open-chat-with/open-chat-with.cpp | 11 ++++++-----
+ kadu-core/gui/windows/open-chat-with/open-chat-with.h | 4 ++--
+ tests/CMakeLists.txt | 2 +-
+ varia/qml/Contact.qml | 2 +-
+ varia/qml/ContactsGridView.qml | 2 +-
+ varia/qml/openChatWith.qml | 2 +-
+ 8 files changed, 14 insertions(+), 13 deletions(-)
+
+diff --git a/cmake/KaduMacros.cmake b/cmake/KaduMacros.cmake
+index ac9e94e..0a7712a 100644
+--- a/cmake/KaduMacros.cmake
++++ b/cmake/KaduMacros.cmake
+@@ -183,7 +183,7 @@ function (kadu_plugin KADU_PLUGIN_NAME)
+ endforeach ()
+ endif ()
+
+- qt5_use_modules (${KADU_PLUGIN_NAME} LINK_PRIVATE Core Gui Widgets Network Xml WebKit WebKitWidgets Declarative)
++ qt5_use_modules (${KADU_PLUGIN_NAME} LINK_PRIVATE Core Gui Network Qml Quick QuickWidgets WebKit WebKitWidgets Widgets Xml)
+ if (UNIX AND NOT APPLE)
+ qt5_use_modules (${KADU_PLUGIN_NAME} LINK_PRIVATE DBus)
+ endif ()
+diff --git a/kadu-core/CMakeLists.txt b/kadu-core/CMakeLists.txt
+index be52339..46317d1 100644
+--- a/kadu-core/CMakeLists.txt
++++ b/kadu-core/CMakeLists.txt
+@@ -205,7 +205,7 @@ if (FAST_LINKING)
+ endif ()
+ endif ()
+
+-qt5_use_modules (libkadu LINK_PRIVATE Core Gui Widgets Xml Network WebKit WebKitWidgets Declarative)
++qt5_use_modules (libkadu LINK_PRIVATE Core Gui Network Qml Quick QuickWidgets WebKit WebKitWidgets Widgets Xml)
+ if (UNIX AND NOT APPLE)
+ qt5_use_modules (libkadu LINK_PRIVATE DBus X11Extras)
+ endif ()
+diff --git a/kadu-core/gui/windows/open-chat-with/open-chat-with.cpp b/kadu-core/gui/windows/open-chat-with/open-chat-with.cpp
+index 2c14c3f..9ff00d1 100644
+--- a/kadu-core/gui/windows/open-chat-with/open-chat-with.cpp
++++ b/kadu-core/gui/windows/open-chat-with/open-chat-with.cpp
+@@ -21,8 +21,9 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+-#include <QtDeclarative/QDeclarativeContext>
+-#include <QtDeclarative/QDeclarativeView>
++#include <QtQml/QQmlContext>
++#include <QtQuick/QQuickItem>
++#include <QtQuickWidgets/QQuickWidget>
+ #include <QtGui/QKeyEvent>
+ #include <QtWidgets/QApplication>
+ #include <QtWidgets/QDesktopWidget>
+@@ -97,18 +98,18 @@ OpenChatWith::OpenChatWith() :
+
+ MainLayout->addWidget(idWidget);
+
+- BuddiesView = new QDeclarativeView();
++ BuddiesView = new QQuickWidget();
+
+ Chain = new ModelChain(this);
+ ListModel = new BuddyListModel(Chain);
+ Chain->setBaseModel(ListModel);
+ Chain->addProxyModel(new TalkableProxyModel(Chain));
+
+- QDeclarativeContext *declarativeContext = BuddiesView->rootContext();
++ QQmlContext *declarativeContext = BuddiesView->rootContext();
+ declarativeContext->setContextProperty("buddies", Chain->lastModel());
+
+ BuddiesView->setSizePolicy(QSizePolicy::Expanding, QSizePolicy::Expanding);
+- BuddiesView->setResizeMode(QDeclarativeView::SizeRootObjectToView);
++ BuddiesView->setResizeMode(QQuickWidget::SizeRootObjectToView);
+ BuddiesView->setSource(QUrl("file:///" + Application::instance()->pathsProvider()->dataPath() + "qml/openChatWith.qml"));
+
+ if (BuddiesView->rootObject())
+diff --git a/kadu-core/gui/windows/open-chat-with/open-chat-with.h b/kadu-core/gui/windows/open-chat-with/open-chat-with.h
+index b079b25..8268d8e 100644
+--- a/kadu-core/gui/windows/open-chat-with/open-chat-with.h
++++ b/kadu-core/gui/windows/open-chat-with/open-chat-with.h
+@@ -29,9 +29,9 @@
+
+ #include "open-chat-with-runner.h"
+
+-class QDeclarativeView;
+ class QLabel;
+ class QPushButton;
++class QQuickWidget;
+ class QVBoxLayout;
+
+ class BuddyListModel;
+@@ -46,7 +46,7 @@ class KADUAPI OpenChatWith : public QWidget, DesktopAwareObject
+
+ explicit OpenChatWith();
+
+- QDeclarativeView *BuddiesView;
++ QQuickWidget *BuddiesView;
+ LineEditWithClearButton *ContactID;
+ QVBoxLayout *MainLayout;
+ OpenChatWithRunner *OpenChatRunner;
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 0dc1dcf..db7c42d 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -31,7 +31,7 @@ function (kadu_add_test name_)
+ endif ()
+ add_test ("${sourcePath}/${name_}" ${name_})
+
+- qt5_use_modules (${name_} LINK_PRIVATE Core Gui Widgets Xml Network WebKit WebKitWidgets Declarative Test)
++ qt5_use_modules (${name_} LINK_PRIVATE Core Gui Network Qml Quick QuickWidgets Test WebKit WebKitWidgets Widgets Xml)
+
+ # Add libkadu after the plugin so that --as-needed won't drop anything
+ # needed by the plugin.
+diff --git a/varia/qml/Contact.qml b/varia/qml/Contact.qml
+index 54a551e..2257348 100644
+--- a/varia/qml/Contact.qml
++++ b/varia/qml/Contact.qml
+@@ -1,4 +1,4 @@
+-import QtQuick 1.1
++import QtQuick 2.3
+
+ Rectangle
+ {
+diff --git a/varia/qml/ContactsGridView.qml b/varia/qml/ContactsGridView.qml
+index 769a419..141931e 100644
+--- a/varia/qml/ContactsGridView.qml
++++ b/varia/qml/ContactsGridView.qml
+@@ -1,4 +1,4 @@
+-import QtQuick 1.1
++import QtQuick 2.3
+
+ Item
+ {
+diff --git a/varia/qml/openChatWith.qml b/varia/qml/openChatWith.qml
+index 317133e..cce65b5 100644
+--- a/varia/qml/openChatWith.qml
++++ b/varia/qml/openChatWith.qml
+@@ -1,4 +1,4 @@
+-import QtQuick 1.1
++import QtQuick 2.3
+
+ Item
+ {
+--
+libgit2 0.24.0
diff --git a/net-im/kadu/kadu-0.12.3.ebuild b/net-im/kadu/kadu-0.12.3.ebuild
index 5eb83a8ef69b..62625bd434b5 100644
--- a/net-im/kadu/kadu-0.12.3.ebuild
+++ b/net-im/kadu/kadu-0.12.3.ebuild
@@ -4,7 +4,7 @@
EAPI="4"
-inherit base cmake-utils flag-o-matic
+inherit cmake-utils flag-o-matic
MY_P="${P/_/-}"
diff --git a/net-im/kadu/kadu-2.1-r1.ebuild b/net-im/kadu/kadu-2.1-r1.ebuild
new file mode 100644
index 000000000000..d8d0125b5b92
--- /dev/null
+++ b/net-im/kadu/kadu-2.1-r1.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit cmake-utils flag-o-matic
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="An open source Gadu-Gadu and Jabber/XMPP protocol Instant Messenger client"
+HOMEPAGE="http://www.kadu.net"
+SRC_URI="http://download.kadu.im/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="+gadu mpd otr phonon sdk speech spell xmpp"
+REQUIRED_USE="
+ || (
+ gadu
+ xmpp
+ )
+"
+COMMON_DEPEND="
+ app-crypt/qca:2[openssl,qt5]
+ >=dev-libs/injeqt-1.0.0
+ >=dev-qt/qtcore-5.2.0:5
+ >=dev-qt/qtdbus-5.2.0:5
+ >=dev-qt/qtdeclarative-5.2.0:5
+ >=dev-qt/qtgui-5.2.0:5
+ >=dev-qt/qtmultimedia-5.2.0:5
+ >=dev-qt/qtnetwork-5.2.0:5
+ >=dev-qt/qtscript-5.2.0:5
+ >=dev-qt/qtsql-5.2.0:5
+ >=dev-qt/qtsvg-5.2.0:5
+ >=dev-qt/qtwebkit-5.2.0:5
+ >=dev-qt/qtwidgets-5.2.0:5
+ >=dev-qt/qtx11extras-5.2.0:5
+ >=dev-qt/qtxml-5.2.0:5
+ >=dev-qt/qtxmlpatterns-5.2.0:5
+ >=app-arch/libarchive-2.6[lzma]
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+ gadu? ( >=net-libs/libgadu-1.11.1[threads] )
+ mpd? ( media-libs/libmpdclient )
+ otr? (
+ >=dev-libs/libgcrypt-1.2.2:0
+ >=net-libs/libotr-4.1.0
+ )
+ phonon? (
+ || (
+ media-libs/phonon[qt5]
+ >=dev-qt/qtphonon-4.7.0:4
+ )
+ )
+ spell? ( app-text/enchant )
+ xmpp? (
+ net-dns/libidn
+ sys-libs/zlib
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-qt/linguist-tools-5.2.0:5
+ x11-proto/scrnsaverproto
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+ speech? ( app-accessibility/powiedz )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-qt5-compilation.patch"
+ "${FILESDIR}/${P}-port-to-QtQuick-2.3.patch"
+)
+
+PLUGINS='
+antistring
+auto_hide
+autoaway
+autoresponder
+autostatus
+cenzor
+chat_notify
+config_wizard
+desktop_docking
+docking
+emoticons
+encryption_ng
+encryption_ng_simlite
+exec_notify
+ext_sound
+falf_mediaplayer
+filedesc
+firewall
+freedesktop_notify
+hints
+history
+idle
+imagelink
+last_seen
+mediaplayer
+mprisplayer_mediaplayer
+pcspeaker
+qt4_docking
+qt4_docking_notify
+screenshot simpleview
+single_window
+sms
+sound
+sql_history
+tabs
+word_fix
+'
+
+src_configure() {
+ # Filter out dangerous flags
+ filter-flags -fno-rtti
+ strip-unsupported-flags
+
+ # Ensure -DQT_NO_DEBUG is added
+ append-cppflags -DQT_NO_DEBUG
+
+ # Plugin selection
+ use gadu && PLUGINS+=' gadu_protocol history_migration profiles_import'
+ use mpd && PLUGINS+=' mpd_mediaplayer'
+ use otr && PLUGINS+=' encryption_otr'
+ use phonon && PLUGINS+=' phonon_sound'
+ use speech && PLUGINS+=' speech'
+ use spell && PLUGINS+=' spellchecker'
+ use xmpp && PLUGINS+=' jabber_protocol'
+
+ # Configure package
+ local mycmakeargs=(
+ -DBUILD_DESCRIPTION='Gentoo Linux'
+ -DCOMPILE_PLUGINS="${PLUGINS}"
+ -DNETWORK_IMPLEMENTATION="Qt"
+ -DINSTALL_SDK=$(usex sdk)
+ -DWITH_ENCHANT=$(usex spell)
+ )
+ unset PLUGINS
+
+ cmake-utils_src_configure
+}
diff --git a/net-im/kadu/kadu-2.1.ebuild b/net-im/kadu/kadu-2.1.ebuild
index 4f9bb7b02cc3..8e0dc7108782 100644
--- a/net-im/kadu/kadu-2.1.ebuild
+++ b/net-im/kadu/kadu-2.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
-inherit base cmake-utils flag-o-matic
+inherit cmake-utils flag-o-matic
MY_P="${P/_/-}"
diff --git a/net-im/kadu/kadu-3.0.ebuild b/net-im/kadu/kadu-3.0.ebuild
new file mode 100644
index 000000000000..f7065483c887
--- /dev/null
+++ b/net-im/kadu/kadu-3.0.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit cmake-utils flag-o-matic
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="An open source Gadu-Gadu and Jabber/XMPP protocol Instant Messenger client"
+HOMEPAGE="http://www.kadu.net"
+SRC_URI="http://download.kadu.im/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="+gadu mpd otr phonon sdk speech spell xmpp"
+REQUIRED_USE="
+ || (
+ gadu
+ xmpp
+ )
+"
+COMMON_DEPEND="
+ app-crypt/qca:2[openssl,qt5]
+ >=dev-libs/injeqt-1.0.0
+ >=dev-qt/qtcore-5.2.0:5
+ >=dev-qt/qtdbus-5.2.0:5
+ >=dev-qt/qtgui-5.2.0:5
+ >=dev-qt/qtmultimedia-5.2.0:5
+ >=dev-qt/qtnetwork-5.2.0:5
+ >=dev-qt/qtscript-5.2.0:5
+ >=dev-qt/qtsql-5.2.0:5
+ >=dev-qt/qtsvg-5.2.0:5
+ >=dev-qt/qtwebkit-5.2.0:5
+ >=dev-qt/qtwidgets-5.2.0:5
+ >=dev-qt/qtx11extras-5.2.0:5
+ >=dev-qt/qtxml-5.2.0:5
+ >=dev-qt/qtxmlpatterns-5.2.0:5
+ >=app-arch/libarchive-2.6[lzma]
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+ gadu? ( >=net-libs/libgadu-1.11.1[threads] )
+ mpd? ( media-libs/libmpdclient )
+ otr? (
+ >=dev-libs/libgcrypt-1.2.2:0
+ >=net-libs/libotr-4.1.0
+ )
+ phonon? (
+ || (
+ media-libs/phonon[qt5]
+ >=dev-qt/qtphonon-4.7.0:4
+ )
+ )
+ spell? ( app-text/enchant )
+ xmpp? (
+ net-dns/libidn
+ >=net-libs/qxmpp-0.8.3[qt5]
+ sys-libs/zlib
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-qt/linguist-tools-5.2.0:5
+ x11-proto/scrnsaverproto
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+ speech? ( app-accessibility/powiedz )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-qt5-compilation.patch"
+)
+
+PLUGINS='
+antistring
+auto_hide
+autoaway
+autoresponder
+autostatus
+cenzor
+chat_notify
+config_wizard
+docking
+docking_notify
+emoticons
+encryption_ng
+encryption_ng_simlite
+exec_notify
+ext_sound
+falf_mediaplayer
+filedesc
+firewall
+freedesktop_notify
+hints
+history
+idle
+imagelink
+last_seen
+mediaplayer
+mprisplayer_mediaplayer
+pcspeaker
+screenshot simpleview
+single_window
+sms
+sound
+sql_history
+tabs
+word_fix
+'
+
+src_configure() {
+ # Filter out dangerous flags
+ filter-flags -fno-rtti
+ strip-unsupported-flags
+
+ # Ensure -DQT_NO_DEBUG is added
+ append-cppflags -DQT_NO_DEBUG
+
+ # Plugin selection
+ use gadu && PLUGINS+=' gadu_protocol history_migration profiles_import'
+ use mpd && PLUGINS+=' mpd_mediaplayer'
+ use otr && PLUGINS+=' encryption_otr'
+ use phonon && PLUGINS+=' phonon_sound'
+ use speech && PLUGINS+=' speech'
+ use spell && PLUGINS+=' spellchecker'
+ use xmpp && PLUGINS+=' jabber_protocol'
+
+ # Configure package
+ local mycmakeargs=(
+ -DBUILD_DESCRIPTION='Gentoo Linux'
+ -DCOMPILE_PLUGINS="${PLUGINS}"
+ -DNETWORK_IMPLEMENTATION="Qt"
+ -DINSTALL_SDK=$(usex sdk)
+ -DWITH_ENCHANT=$(usex spell)
+ )
+ unset PLUGINS
+
+ cmake-utils_src_configure
+}