summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/minbif/files/minbif.initd4
-rw-r--r--net-im/minbif/minbif-1.0.5-r1.ebuild2
-rw-r--r--net-im/minbif/minbif-1.0.5-r2.ebuild84
3 files changed, 87 insertions, 3 deletions
diff --git a/net-im/minbif/files/minbif.initd b/net-im/minbif/files/minbif.initd
index a2d5649bfe1f..ce5266397db7 100644
--- a/net-im/minbif/files/minbif.initd
+++ b/net-im/minbif/files/minbif.initd
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2009 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/net-im/minbif/minbif-1.0.5-r1.ebuild b/net-im/minbif/minbif-1.0.5-r1.ebuild
index 1586a3d525be..0262b1a52067 100644
--- a/net-im/minbif/minbif-1.0.5-r1.ebuild
+++ b/net-im/minbif/minbif-1.0.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/net-im/minbif/minbif-1.0.5-r2.ebuild b/net-im/minbif/minbif-1.0.5-r2.ebuild
new file mode 100644
index 000000000000..0262b1a52067
--- /dev/null
+++ b/net-im/minbif/minbif-1.0.5-r2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils eutils user
+
+DESCRIPTION="an IRC gateway to IM networks"
+HOMEPAGE="https://symlink.me/projects/minbif/wiki/"
+SRC_URI="https://symlink.me/attachments/download/148/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="gnutls +imlib +libcaca pam xinetd"
+REQUIRED_USE="
+ libcaca? ( imlib )
+"
+
+DEPEND="
+ >=net-im/pidgin-2.6
+ libcaca? ( media-libs/libcaca media-libs/imlib2 )
+ imlib? ( media-libs/imlib2 )
+ pam? ( sys-libs/pam )
+ gnutls? ( net-libs/gnutls )
+"
+RDEPEND="${DEPEND}
+ virtual/logger
+ xinetd? ( sys-apps/xinetd )
+"
+
+pkg_setup() {
+ enewgroup minbif
+ enewuser minbif -1 -1 /var/lib/minbif minbif
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.0.5-glib-single-includes.patch"
+ epatch "${FILESDIR}/${PN}-1.0.5-gcc47.patch"
+
+ sed -i "s/-Werror//g" CMakeLists.txt || die "sed failed"
+
+ sed -i "s#share/doc/minbif#share/doc/${P}#" \
+ CMakeLists.txt || die "sed failed"
+
+ if use xinetd; then
+ sed -i "s/type\s=\s[0-9]/type = 0/" \
+ minbif.conf || die "sed failed"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs
+ mycmakeargs="${mycmakeargs}
+ -DCONF_PREFIX=${PREFIX:-/etc/minbif}
+ -DENABLE_VIDEO=OFF
+ $(cmake-utils_use_enable libcaca CACA)
+ $(cmake-utils_use_enable imlib IMLIB)
+ $(cmake-utils_use_enable pam PAM)
+ $(cmake-utils_use_enable gnutls TLS)"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ keepdir /var/lib/minbif
+ fperms 700 /var/lib/minbif
+ fowners minbif:minbif /var/lib/minbif
+
+ dodoc ChangeLog README
+ doman man/minbif.8
+
+ if use xinetd; then
+ insinto /etc/xinetd.d
+ newins doc/minbif.xinetd minbif
+ fi
+
+ newinitd "${FILESDIR}"/minbif.initd minbif
+
+ dodir /usr/share/minbif
+ insinto /usr/share/minbif
+ doins -r scripts
+}