summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/anope')
-rw-r--r--net-irc/anope/anope-2.0.6.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-irc/anope/anope-2.0.6.ebuild b/net-irc/anope/anope-2.0.6.ebuild
index 1cf036e12d83..2953f690d0dc 100644
--- a/net-irc/anope/anope-2.0.6.ebuild
+++ b/net-irc/anope/anope-2.0.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils user
+inherit cmake user
DESCRIPTION="Anope IRC Services"
HOMEPAGE="https://anope.org"
@@ -98,7 +98,7 @@ src_prepare() {
# Avoid a silly sandbox error - tries to delete /usr/lib/modules
sed -i '/install.*REMOVE_RECURSE.*/d' CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -111,11 +111,11 @@ src_configure() {
-DCONF_DIR="/etc/anope"
-DLOGS_DIR="../var/log/anope/"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
newinitd "${FILESDIR}/anope-init.d" "${PN}"
cp "${FILESDIR}/anope-conf.d-v2" "${T}" || die
sed -i "s~%LIBDIR%~${EPREFIX}/usr/$(get_libdir)/anope/~" \