summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/bnc/files/bnc-2.9.4-build.patch')
-rw-r--r--net-irc/bnc/files/bnc-2.9.4-build.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-irc/bnc/files/bnc-2.9.4-build.patch b/net-irc/bnc/files/bnc-2.9.4-build.patch
new file mode 100644
index 000000000000..b6fb97623729
--- /dev/null
+++ b/net-irc/bnc/files/bnc-2.9.4-build.patch
@@ -0,0 +1,33 @@
+--- Makefile.in
++++ Makefile.in
+@@ -1,8 +1,17 @@
+ LIBS=@LIBS@
+-CFLAGS=-O3 -Wall -include config.h
++CFLAGS=@CFLAGS@ -Wall -include config.h
+ CC=@CC@
++
++DESTDIR =
++prefix = @prefix@
++exec_prefix = @exec_prefix@
++bindir = @bindir@
+
+-ALL: bnc mkpasswd
++all ALL: bnc mkpasswd
++
++install: bnc mkpasswd
++ install -m 755 -d $(DESTDIR)$(bindir)
++ install -m 755 bnc mkpasswd bncchk bncsetup $(DESTDIR)$(bindir)
+
+ mkpasswd:mkpasswd.c
+ ${CC} ${CFLAGS} -o mkpasswd mkpasswd.c ${LIBS}
+--- configure.in
++++ configure.in
+@@ -35,7 +35,7 @@
+ dnl Check for SSL support.
+ AC_MSG_CHECKING(whether to enable SSL support)
+ AC_ARG_WITH(ssl,
+-[ -with-ssl Enable SSL support],
++[ --with-ssl Enable SSL support],
+ [ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)