summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/ii/ii-1.8.ebuild')
-rw-r--r--net-irc/ii/ii-1.8.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/net-irc/ii/ii-1.8.ebuild b/net-irc/ii/ii-1.8.ebuild
index 77abe790e335..be2821b3f793 100644
--- a/net-irc/ii/ii-1.8.ebuild
+++ b/net-irc/ii/ii-1.8.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit toolchain-funcs
DESCRIPTION="A minimalist FIFO and filesystem-based IRC client"
@@ -10,19 +10,13 @@ SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 arm ~ppc ~ppc64 x86 ~amd64-linux"
+KEYWORDS="amd64 arm ~arm64 ~ppc ~ppc64 x86 ~amd64-linux"
src_prepare() {
default
- sed -i \
- -e '/^CFLAGS/{s: -Os::g; s:= :+= :g}' \
- -e '/^CC/d' \
- -e '/^LDFLAGS/{s:-s::g; s:= :+= :g}' \
- config.mk || die
- sed -i \
- -e 's|@${CC}|$(CC)|g' \
- Makefile || die
+ sed -i -e '/^LDFLAGS/{s:-s::g; s:= :+= :g}' \
+ -e '/^CFLAGS/{s: -Os::g; s:= :+= :g}' config.mk || die
}
src_compile() {
@@ -30,7 +24,9 @@ src_compile() {
}
src_install() {
- dobin ii
- dodoc CHANGES FAQ README
- doman *.1
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ install
}