summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/iroffer-dinoex')
-rw-r--r--net-irc/iroffer-dinoex/Manifest1
-rw-r--r--net-irc/iroffer-dinoex/iroffer-dinoex-3.32.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/net-irc/iroffer-dinoex/Manifest b/net-irc/iroffer-dinoex/Manifest
index c2972b6816e2..a414aafd6c08 100644
--- a/net-irc/iroffer-dinoex/Manifest
+++ b/net-irc/iroffer-dinoex/Manifest
@@ -1,2 +1,3 @@
DIST iroffer-dinoex-3.30.tar.gz 541131 BLAKE2B ea61113dffcd14b162153aa03c55a203d8ccd99e8f81de53a9ab8543bd91e948509281f753a8f332445eec102b6bd2b51972ff8bedb8b574b55b9325f6969269 SHA512 e45dc3dd901cbb73a9d59cd5a672834c7b6527864eb3385121856af562680a0f91e8846e8690fc60a6349dc4c4fc1cf190d3ac01813c6c045ef18147d61b7d4d
DIST iroffer-dinoex-3.31.tar.gz 527712 BLAKE2B 8e57058af9aad9537d29a15140ab59c921d2549eb9e7a2ce9145fc1c27a4307bea882927012b04fc9f0737a8853d927c79cc0f3156dfa311072c59589fe0221f SHA512 677aa03a33b99d8062db077bba47fb18b2e9279243691981bbd09cb2859fcb4792e1383225b9698edb23370ce0f60667a09480644d31171e9a8234d80052dd80
+DIST iroffer-dinoex-3.32.tar.gz 1321125 BLAKE2B 3a124d16911d97d0ec937b86c9e0ad513ebdcea5e09e4cb1a53753c03d5e13347d0bf1116bf9abe0137fb7a05bbc7a8e31c2c0da5c15cc4e0b55e067d62b1461 SHA512 03d662cf7eb3093b1f050eda8777011d6e7a833dc2fcf65d29ef0294a0d6ce4e2cea273e2d4e6ee6ba2364c088890ac6338a3aa8e6477d5e2a1a990a6e4e9603
diff --git a/net-irc/iroffer-dinoex/iroffer-dinoex-3.32.ebuild b/net-irc/iroffer-dinoex/iroffer-dinoex-3.32.ebuild
new file mode 100644
index 000000000000..2f525ffe3ffb
--- /dev/null
+++ b/net-irc/iroffer-dinoex/iroffer-dinoex-3.32.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLOCALES="de en fr it"
+PLOCALE_BACKUP="en"
+
+inherit l10n toolchain-funcs user
+
+DESCRIPTION="IRC fileserver using DCC"
+HOMEPAGE="http://iroffer.dinoex.net/"
+SRC_URI="http://iroffer.dinoex.net/${P}.tar.gz
+ http://iroffer.dinoex.net/HISTORY/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+admin +blowfish +chroot curl debug geoip gnutls +http kqueue +memsave ruby ssl +telnet upnp"
+
+REQUIRED_USE="
+ admin? ( http )
+ gnutls? ( ssl )
+"
+
+RDEPEND="chroot? ( dev-libs/nss )
+ curl? (
+ net-misc/curl[ssl?]
+ gnutls? ( net-misc/curl[curl_ssl_gnutls] )
+ !gnutls? ( ssl? ( net-misc/curl[curl_ssl_openssl] ) )
+ )
+ geoip? ( dev-libs/geoip )
+ gnutls? ( net-libs/gnutls )
+ ruby? ( dev-lang/ruby:* )
+ ssl? ( !gnutls? ( dev-libs/openssl:0= ) )"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ enewgroup iroffer
+ enewuser iroffer -1 -1 -1 iroffer
+}
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-3.31-config.patch"
+ eapply "${FILESDIR}/${PN}-Werror.patch"
+
+ eapply_user
+
+ l10n_find_plocales_changes "" 'help-admin-' '.txt'
+}
+
+do_configure() {
+ echo ./Configure $*
+ ./Configure $* || die "configure phase failed"
+}
+
+src_configure() {
+ do_configure \
+ PREFIX="${EPREFIX}/usr"\
+ $(usex debug '-profiling' '' '' '')\
+ $(usex debug '-debug' '' '' '')\
+ $(usex geoip '-geoip' '' '' '')\
+ $(usex chroot '' '-no-chroot' '' '')\
+ $(usex curl '-curl' '' '' '' )\
+ $(usex gnutls '-tls' '' '' '' '')\
+ $(usex upnp '-upnp' '' '' '')\
+ $(usex ruby '-ruby' '' '' '')\
+ $(usex kqueue '-kqueue' '' '' '')\
+ $(usex blowfish '' '-no-blowfish' '' '')\
+ $(usex ssl '' '-no-openssl' '' '')\
+ $(usex http '' '-no-http' '' '')\
+ $(usex admin '' '-no-admin' '' '')\
+ $(usex telnet '' '-no-telnet' '' '')\
+ $(usex memsave '' '-no-memsave' '' '')
+}
+
+src_compile() {
+ # TODO: default compile targets always include chrooted target, which is not good
+ emake CC="$(tc-getCC)" $(l10n_get_locales)
+}
+
+myloc() {
+ emake DESTDIR="${D}" install-${1}
+
+ dodoc help-admin-${1}.txt
+ use http && dodoc doc/INSTALL-linux-${1}.html
+
+ insinto /etc/${PN}
+ case ${1} in
+ "de")
+ doins beispiel.config;;
+ "fr")
+ doins exemple.config;;
+ *)
+ doins sample.config;;
+ esac
+}
+
+src_install() {
+ l10n_for_each_locale_do myloc
+
+ dodoc README* THANKS TODO
+ doman iroffer.1 xdcc.7
+
+ newinitd "${FILESDIR}/${PN}.init" ${PN}
+ newconfd "${FILESDIR}/${PN}.conf" ${PN}
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+ if use ruby; then
+ insinto /usr/share/${PN}
+ doins ruby-sample.rb
+ fi
+
+ if use http; then
+ insinto /usr/share/${PN}/htdocs
+ doins htdocs/*
+ fi
+}