summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/http-parser/http-parser-2.3.ebuild')
-rw-r--r--net-libs/http-parser/http-parser-2.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-libs/http-parser/http-parser-2.3.ebuild b/net-libs/http-parser/http-parser-2.3.ebuild
new file mode 100644
index 000000000000..c82c8a441a65
--- /dev/null
+++ b/net-libs/http-parser/http-parser-2.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SONAMEVER="2.3"
+SONAME="libhttp_parser.so.${SONAMEVER}"
+
+inherit eutils toolchain-funcs multilib multilib-minimal
+
+DESCRIPTION="A parser for HTTP messages written in C. It parses both requests and responses"
+HOMEPAGE="https://github.com/joyent/http-parser"
+SRC_URI="https://github.com/joyent/http-parser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${SONAMEVER}"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE="static-libs"
+
+src_prepare() {
+ tc-export CC AR
+ epatch "${FILESDIR}"/${P}-flags.patch
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake library
+ use static-libs && emake package
+}
+
+multilib_src_install() {
+ doheader http_parser.h
+ dolib.so ${SONAME}
+ dosym ${SONAME} /usr/$(get_libdir)/libhttp_parser.so
+ use static-libs && dolib.a libhttp_parser.a
+}
+
+multilib_src_install_all() {
+ dodoc README.md
+}