summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/autoupnp/autoupnp-9999.ebuild')
-rw-r--r--net-misc/autoupnp/autoupnp-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/autoupnp/autoupnp-9999.ebuild b/net-misc/autoupnp/autoupnp-9999.ebuild
new file mode 100644
index 000000000000..f9ce1293d53b
--- /dev/null
+++ b/net-misc/autoupnp/autoupnp-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-r3
+#endif
+
+inherit autotools-utils
+
+DESCRIPTION="Automatic open port forwarder using UPnP"
+HOMEPAGE="https://bitbucket.org/mgorny/autoupnp/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="net-libs/miniupnpc:0=
+ libnotify? ( x11-libs/libtinynotify:0= )"
+DEPEND="${RDEPEND}"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+src_configure() {
+ myeconfargs=(
+ $(use_with libnotify)
+ )
+
+ autotools-utils_src_configure
+}