summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/connect/connect-1.103.ebuild')
-rw-r--r--net-misc/connect/connect-1.103.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/connect/connect-1.103.ebuild b/net-misc/connect/connect-1.103.ebuild
new file mode 100644
index 000000000000..e1ba3ae9ab7d
--- /dev/null
+++ b/net-misc/connect/connect-1.103.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit toolchain-funcs
+
+IUSE=""
+DESCRIPTION="network connection relaying command (proxy)"
+HOMEPAGE="https://bitbucket.org/gotoh/connect"
+HG_COMMIT_ID="ee1fbc21da4b" # bitbucket commit id
+#SRC_URI="https://www.bitbucket.org/gotoh/connect/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI="http://bitbucket.org/gotoh/connect/get/${HG_COMMIT_ID}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND=""
+RDEPEND=""
+S="${WORKDIR}/gotoh-connect-${HG_COMMIT_ID}"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c || die "compilation failed"
+}
+
+src_install() {
+ dobin ${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "There is no manpage."
+ einfo "Please see https://bitbucket.org/gotoh/connect/wiki/Home for details."
+ einfo
+}