summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/geoipupdate/geoipupdate-2.2.1.ebuild')
-rw-r--r--net-misc/geoipupdate/geoipupdate-2.2.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-misc/geoipupdate/geoipupdate-2.2.1.ebuild b/net-misc/geoipupdate/geoipupdate-2.2.1.ebuild
new file mode 100644
index 000000000000..255652d2792f
--- /dev/null
+++ b/net-misc/geoipupdate/geoipupdate-2.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="performs automatic updates of GeoIP2 and GeoIP Legacy binary databases"
+HOMEPAGE="https://github.com/maxmind/geoipupdate"
+SRC_URI="https://github.com/maxmind/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="
+ net-misc/curl
+ sys-libs/zlib
+"
+RDEPEND="
+ ${DEPEND}
+ !<dev-libs/geoip-1.6.0
+"
+
+src_install() {
+ default
+ keepdir /usr/share/GeoIP
+}