summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/jwhois/jwhois-4.0.ebuild')
-rw-r--r--net-misc/jwhois/jwhois-4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/jwhois/jwhois-4.0.ebuild b/net-misc/jwhois/jwhois-4.0.ebuild
new file mode 100644
index 000000000000..e13c9f38d4e6
--- /dev/null
+++ b/net-misc/jwhois/jwhois-4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Advanced Internet Whois client capable of recursive queries"
+HOMEPAGE="http://www.gnu.org/software/jwhois/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ~ppc ppc64 s390 sh sparc x86"
+IUSE="idn nls"
+
+DEPEND="idn? ( net-dns/libidn )"
+
+src_compile() {
+ econf \
+ --localstatedir=/var/cache \
+ --without-cache \
+ $(use_enable nls) \
+ $(use_with idn libidn) \
+ || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}