summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/stuntman/stuntman-1.2.6.ebuild')
-rw-r--r--net-misc/stuntman/stuntman-1.2.6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/stuntman/stuntman-1.2.6.ebuild b/net-misc/stuntman/stuntman-1.2.6.ebuild
new file mode 100644
index 000000000000..8edb1947cfdf
--- /dev/null
+++ b/net-misc/stuntman/stuntman-1.2.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="STUNTMAN is an open source implementation of the STUN protocol"
+HOMEPAGE="http://www.stunprotocol.org"
+SRC_URI="http://www.stunprotocol.org/stunserver-${PV}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/boost
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/stunserver"
+
+src_compile()
+{
+ emake T=""
+}
+
+src_install()
+{
+ dobin stunclient
+ dosbin stunserver
+ dodoc HISTORY README
+ newinitd "${FILESDIR}/initd.v1" stuntman
+}
+
+src_test()
+{
+ ./stuntestcode
+}