summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nds/gss-proxy')
-rw-r--r--net-nds/gss-proxy/Manifest3
-rwxr-xr-xnet-nds/gss-proxy/files/gssproxy15
-rw-r--r--net-nds/gss-proxy/gss-proxy-0.7.0-r1.ebuild89
-rw-r--r--net-nds/gss-proxy/gss-proxy-0.8.0.ebuild89
-rw-r--r--net-nds/gss-proxy/metadata.xml7
5 files changed, 0 insertions, 203 deletions
diff --git a/net-nds/gss-proxy/Manifest b/net-nds/gss-proxy/Manifest
deleted file mode 100644
index 78f367107f32..000000000000
--- a/net-nds/gss-proxy/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST gssproxy-0.7.0.tar.gz 552041 BLAKE2B 78ec58e151c801ea65e01bf12ac38591442073eef051302afbbd8c11e20c753ae481542a9cdaeb321551ac1ba14be5875b5dc0f9514a0d436bc28e71a5d28c9e SHA512 00cd1d05e12f93f81c11062ccf4950e521960f752a6121f2055e47294a51894eda2415c558d3bc0d4c496146ab8f82a1162328acfb5eb3405c7b116774fa9f89
-DIST gssproxy-0.8.0.tar.gz 557386 BLAKE2B 14948bbd4c08834375ed00d9f9c6624797eadef3a4313af55a3f3cc9fa3133627ed11da97c1414caa1731ef6da1286dbc1e1c41af8e6c4f96dd42e5b0b2b69e6 SHA512 f3b8f053d6750d7ee6ab2bfb6bfc4dc1ac2e2f354f923590340bb3c522f57cc881df5a2850750bc00c0dcacf2ae173549dc3bb9ece4512cf2f39869527afc2ec
-DIST gssproxy-0.8.2.tar.gz 563300 BLAKE2B 104637af6f43d118ef5194ee8bdfd0a8a8155df43691ac80394de0482f718f2672996b698a80d5c4db7bdc1b164be7f8dc6ffd9a5346affd5923b78362f10333 SHA512 68ce39b36ee83d77da19e9a9fb322ba901366999828a2b427bc2275c4187b4d2291de140c202cce02bdf53eb5cf64da2fafa022ea482258c102f28b0af5d7c63
diff --git a/net-nds/gss-proxy/files/gssproxy b/net-nds/gss-proxy/files/gssproxy
deleted file mode 100755
index 8c29f899f2ca..000000000000
--- a/net-nds/gss-proxy/files/gssproxy
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-command="gssproxy"
-command_args="-D"
-pidfile="/var/run/gssproxy.pid"
-
-depend() {
- use logger
-}
-
-start_pre() {
- checkpath -d -m 0755 /var/lib/gssproxy
-}
diff --git a/net-nds/gss-proxy/gss-proxy-0.7.0-r1.ebuild b/net-nds/gss-proxy/gss-proxy-0.7.0-r1.ebuild
deleted file mode 100644
index 70b3508e2eec..000000000000
--- a/net-nds/gss-proxy/gss-proxy-0.7.0-r1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_P="${PN/-}-${PV}"
-
-DESCRIPTION="daemon to proxy GSSAPI context establishment and channel handling"
-HOMEPAGE="https://pagure.io/gssproxy"
-SRC_URI="http://releases.pagure.org/gssproxy/${MY_P}.tar.gz"
-
-LICENSE="BSD-1"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="debug selinux systemd hardened"
-
-COMMON_DEPEND=">=dev-libs/libverto-0.2.2
- >=dev-libs/ding-libs-0.5.0
- virtual/krb5
- selinux? ( sys-libs/libselinux )"
-RDEPEND="${COMMON_DEPEND}
- selinux? ( sec-policy/selinux-gssproxy )"
-# We need xml stuff to build the man pages, and people really want/need
-# the man pages for this package :). #585200
-DEPEND="${COMMON_DEPEND}
- app-text/docbook-xml-dtd:4.4
- dev-libs/libxslt
- virtual/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-# Many requirements to run tests, including running slapd as root, hence
-# unfeasible.
-RESTRICT="test"
-
-# pkg_setup() {
-# # Here instead of flag-logic in DEPEND, since virtual/krb5 does not
-# # allow to specify the openldap use flag, which heimdal doesn't
-# # support.
-# # Using mit-krb5 explicitly because heimdal doesn't install kerberos
-# # schemata required for the tests of gss-proxy.
-# if use test && ! has_version "app-crypt/mit-krb5[openldap]"; then
-# eerror "Tests of this package require the kerberos schemata installed from app-crypt/mit-krb5[openldap]."
-# die "Tests enabled but no app-crypt/mit-krb5[openldap] being installed."
-# fi
-# }
-
-# Was required in 0.7.0 to fix the schema- and slapd-path. Reason for
-# comment: see RESTRICT comment
-# src_prepare() {
-# default
-# # The tests look for kerberos schemata in the documentation
-# # directory of krb5, however these are installed in /etc/openldap
-# # and only if the openldap useflag is supplied
-# sed -i \
-# -e 's#/usr/share/doc/krb5-server-ldap*#/etc/openldap/schema#' \
-# -e "s#\(subprocess.Popen..\"\)slapd#\1/usr/$(get_libdir)/openldap/slapd#" \
-# "${S}/tests/testlib.py" || die
-# }
-
-src_configure() {
- local myeconfargs=(
- # The build assumes localstatedir is /var and takes care of
- # using all the right subdirs itself.
- "--localstatedir=${EPREFIX}/var"
- "--with-os=gentoo"
- "--with-initscript=$(usex systemd systemd none)"
- "$(use_with selinux)"
- "$(use_with debug gssidebug)"
- "$(use_with hardened hardening)"
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- # This is a plugin module, so no need for la file.
- find "${ED%/}"/usr -name proxymech.la -delete
-
- doinitd "${FILESDIR}"/gssproxy
- insinto /etc/gssproxy
- doins examples/*.conf
- insinto /etc/gss/mech.d
- newins examples/mech gssproxy.conf
-
- # The build installs a bunch of empty dirs, so prune them.
- find "${ED}" -depth -type d -exec rmdir {} + 2>/dev/null
-}
diff --git a/net-nds/gss-proxy/gss-proxy-0.8.0.ebuild b/net-nds/gss-proxy/gss-proxy-0.8.0.ebuild
deleted file mode 100644
index 7939c3e2191f..000000000000
--- a/net-nds/gss-proxy/gss-proxy-0.8.0.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_P="${PN/-}-${PV}"
-
-DESCRIPTION="daemon to proxy GSSAPI context establishment and channel handling"
-HOMEPAGE="https://pagure.io/gssproxy"
-SRC_URI="http://releases.pagure.org/gssproxy/${MY_P}.tar.gz"
-
-LICENSE="BSD-1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="debug selinux systemd hardened"
-
-COMMON_DEPEND=">=dev-libs/libverto-0.2.2
- >=dev-libs/ding-libs-0.6.1
- virtual/krb5
- selinux? ( sys-libs/libselinux )"
-RDEPEND="${COMMON_DEPEND}
- selinux? ( sec-policy/selinux-gssproxy )"
-# We need xml stuff to build the man pages, and people really want/need
-# the man pages for this package :). #585200
-DEPEND="${COMMON_DEPEND}
- app-text/docbook-xml-dtd:4.4
- dev-libs/libxslt
- virtual/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-# Many requirements to run tests, including running slapd as root, hence
-# unfeasible.
-RESTRICT="test"
-
-# pkg_setup() {
-# # Here instead of flag-logic in DEPEND, since virtual/krb5 does not
-# # allow to specify the openldap use flag, which heimdal doesn't
-# # support.
-# # Using mit-krb5 explicitly because heimdal doesn't install kerberos
-# # schemata required for the tests of gss-proxy.
-# if use test && ! has_version "app-crypt/mit-krb5[openldap]"; then
-# eerror "Tests of this package require the kerberos schemata installed from app-crypt/mit-krb5[openldap]."
-# die "Tests enabled but no app-crypt/mit-krb5[openldap] being installed."
-# fi
-# }
-
-# Was required in 0.7.0 to fix the schema- and slapd-path. Reason for
-# comment: see RESTRICT comment
-# src_prepare() {
-# default
-# # The tests look for kerberos schemata in the documentation
-# # directory of krb5, however these are installed in /etc/openldap
-# # and only if the openldap useflag is supplied
-# sed -i \
-# -e 's#/usr/share/doc/krb5-server-ldap*#/etc/openldap/schema#' \
-# -e "s#\(subprocess.Popen..\"\)slapd#\1/usr/$(get_libdir)/openldap/slapd#" \
-# "${S}/tests/testlib.py" || die
-# }
-
-src_configure() {
- local myeconfargs=(
- # The build assumes localstatedir is /var and takes care of
- # using all the right subdirs itself.
- "--localstatedir=${EPREFIX}/var"
- "--with-os=gentoo"
- "--with-initscript=$(usex systemd systemd none)"
- "$(use_with selinux)"
- "$(use_with debug gssidebug)"
- "$(use_with hardened hardening)"
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- # This is a plugin module, so no need for la file.
- find "${ED%/}"/usr -name proxymech.la -delete
-
- doinitd "${FILESDIR}"/gssproxy
- insinto /etc/gssproxy
- doins examples/*.conf
- insinto /etc/gss/mech.d
- newins examples/mech gssproxy.conf
-
- # The build installs a bunch of empty dirs, so prune them.
- find "${ED}" -depth -type d -exec rmdir {} + 2>/dev/null
-}
diff --git a/net-nds/gss-proxy/metadata.xml b/net-nds/gss-proxy/metadata.xml
deleted file mode 100644
index aebca33be179..000000000000
--- a/net-nds/gss-proxy/metadata.xml
+++ /dev/null
@@ -1,7 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>base-system@gentoo.org</email>
-</maintainer>
-</pkgmetadata>