summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nds/rpcbind')
-rw-r--r--net-nds/rpcbind/Manifest1
-rw-r--r--net-nds/rpcbind/files/rpcbind-0.2.4-CVE-2017-8779.patch21
-rw-r--r--net-nds/rpcbind/rpcbind-0.2.4-r3.ebuild58
3 files changed, 0 insertions, 80 deletions
diff --git a/net-nds/rpcbind/Manifest b/net-nds/rpcbind/Manifest
index f3285ad88147..1e114d6b58e5 100644
--- a/net-nds/rpcbind/Manifest
+++ b/net-nds/rpcbind/Manifest
@@ -1,2 +1 @@
-DIST rpcbind-0.2.4.tar.bz2 122781 BLAKE2B ac1c374a1081559bf09bc209256daa1bb530d71f0c7fe45cec4c9b87cf110c15251a05dce2cf2b78ffa4d902f817efed30350ad08a23e12a7f219f10fe626aa8 SHA512 f3966a7284e94bdf120a9b3f0dd66efa1fe8761df2313545a031f77b7c06e27d7955d2780469943deb537d34f95c4cf3f30de523ec9fab9f571322d7224b210c
DIST rpcbind-1.2.5.tar.bz2 123502 BLAKE2B de0d10406aeffd75195c1fa1d0179b2c7c0ba54c3f3ac58ce9d7e9448d1dbe91a296ad69c45dee115e0a739aa9cfec53b750d3a5ca405e16605a92bbb2006859 SHA512 e884c4757950ccead0f9a07f50625a63e6f18f9bfae9fcfffa3e5fa4b7a66c3a99d9fa303061848fe8211509d5456f24ff26e4579af6e161a35522268f3ef3e4
diff --git a/net-nds/rpcbind/files/rpcbind-0.2.4-CVE-2017-8779.patch b/net-nds/rpcbind/files/rpcbind-0.2.4-CVE-2017-8779.patch
deleted file mode 100644
index cef088badc91..000000000000
--- a/net-nds/rpcbind/files/rpcbind-0.2.4-CVE-2017-8779.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/src/rpcb_svc_com.c b/src/rpcb_svc_com.c
-index 5862c26..e11f61b 100644
---- a/src/rpcb_svc_com.c
-+++ b/src/rpcb_svc_com.c
-@@ -48,6 +48,7 @@
- #include <rpc/rpc.h>
- #include <rpc/rpcb_prot.h>
- #include <rpc/svc_dg.h>
-+#include <rpc/rpc_com.h>
- #include <netconfig.h>
- #include <errno.h>
- #include <syslog.h>
-@@ -432,7 +433,7 @@ rpcbproc_taddr2uaddr_com(void *arg, struct svc_req *rqstp /*__unused*/,
- static bool_t
- xdr_encap_parms(XDR *xdrs, struct encap_parms *epp)
- {
-- return (xdr_bytes(xdrs, &(epp->args), (u_int *) &(epp->arglen), ~0));
-+ return (xdr_bytes(xdrs, &(epp->args), (u_int *) &(epp->arglen), RPC_MAXDATASIZE));
- }
-
- /*
diff --git a/net-nds/rpcbind/rpcbind-0.2.4-r3.ebuild b/net-nds/rpcbind/rpcbind-0.2.4-r3.ebuild
deleted file mode 100644
index 8431b518c940..000000000000
--- a/net-nds/rpcbind/rpcbind-0.2.4-r3.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils systemd
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://linux-nfs.org/~steved/rpcbind.git"
- inherit autotools git-r3
-else
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-fi
-
-DESCRIPTION="portmap replacement which supports RPC over various protocols"
-HOMEPAGE="https://sourceforge.net/projects/rpcbind/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="debug selinux systemd tcpd warmstarts"
-REQUIRED_USE="systemd? ( warmstarts )"
-
-CDEPEND=">=net-libs/libtirpc-1.0:=
- systemd? ( sys-apps/systemd:= )
- tcpd? ( sys-apps/tcp-wrappers )"
-DEPEND="${CDEPEND}
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-rpcbind )"
-
-PATCHES=(
- "${FILESDIR}/${P}-CVE-2017-8779.patch"
-)
-
-src_prepare() {
- [[ ${PV} == "9999" ]] && eautoreconf
- epatch "${PATCHES[@]}"
- epatch_user
-}
-
-src_configure() {
- econf \
- --bindir="${EPREFIX}"/sbin \
- --with-statedir="${EPREFIX}"/run/${PN} \
- --with-rpcuser=root \
- --with-systemdsystemunitdir=$(usex systemd "$(systemd_get_unitdir)" "no") \
- $(use_enable tcpd libwrap) \
- $(use_enable debug) \
- $(use_enable warmstarts)
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
-}