summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/gss-proxy/Manifest1
-rw-r--r--net-nds/gss-proxy/gss-proxy-0.5.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-nds/gss-proxy/Manifest b/net-nds/gss-proxy/Manifest
index 00e357a45134..497ea353d31b 100644
--- a/net-nds/gss-proxy/Manifest
+++ b/net-nds/gss-proxy/Manifest
@@ -1 +1,2 @@
DIST gssproxy-0.5.0.tar.gz 526047 SHA256 0965448e145b0d764ba5ca7707a7bf3d2c9d555f96fcb3ba0d88673a233b31d6 SHA512 14a50583fa304a667243b470415d107026042871374b69e5c5ff82ceb7ae9fd83532241ac032e79e87cea1706970ea0d552f5fc31a0340e22242f4cc4abd5cf8 WHIRLPOOL 9352644e76ba96a0c36640d0cc703f74b5ba48f980edb668f1c98efedab5e9d16c094080af950ba94cf9ceac88bf10f3b68876e83942ae4cafb9d7ddd74ec486
+DIST gssproxy-0.5.1.tar.gz 532525 SHA256 b7ac0b75dcd62264f9ffef4ab0aa14534b850873ada08209ba467e5914643fbd SHA512 72cb987413feba341b57caa27d5efadb8ed63af3751fda7013fe68768457a88011ac3bcf6e90b3d1d5ecf8894708daa0f20e57fe191d8ba3ce9b6492b57708f7 WHIRLPOOL 514e58fab7ad18707d4edd66aafd8aa1ee4f74e045ac5aa47bef50f55c3a2f7dd297ff4504be3ff1f7709abf9b3fd734d023781c25f76fb6e55e950e85acae4c
diff --git a/net-nds/gss-proxy/gss-proxy-0.5.1.ebuild b/net-nds/gss-proxy/gss-proxy-0.5.1.ebuild
new file mode 100644
index 000000000000..7abf2d67a635
--- /dev/null
+++ b/net-nds/gss-proxy/gss-proxy-0.5.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+MY_P="${PN/-}-${PV}"
+
+DESCRIPTION="daemon to proxy GSSAPI context establishment and channel handling"
+HOMEPAGE="https://fedorahosted.org/gss-proxy/"
+SRC_URI="https://fedorahosted.org/released/gss-proxy/${MY_P}.tar.gz"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug selinux systemd"
+
+RDEPEND=">=dev-libs/libverto-0.2.2
+ >=dev-libs/ding-libs-0.5.0
+ virtual/krb5
+ selinux? ( sys-libs/libselinux )"
+# We need xml stuff to build the man pages, and people really want/need
+# the man pages for this package :). #585200
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.4
+ dev-libs/libxslt
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # The build assumes localstatedir is /var and takes care of
+ # using all the right subdirs itself.
+ econf \
+ --localstatedir="${EPREFIX}/var" \
+ --with-os=gentoo \
+ --with-initscript=$(usex systemd systemd sysv) \
+ $(use_with selinux) \
+ $(use_with debug gssidebug)
+}
+
+src_install() {
+ default
+ # This is a plugin module, so no need for la file.
+ find "${ED}"/usr -name proxymech.la -delete
+
+ doinitd "${FILESDIR}"/gssproxy
+ insinto /etc/gssproxy
+ doins examples/*.conf
+ insinto /etc/gss/mech.d
+ newins examples/mech gssproxy.conf
+
+ # The build installs a bunch of empty dirs, so prune them.
+ find "${ED}" -depth -type d -exec rmdir {} + 2>/dev/null
+}