summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/liferea')
-rw-r--r--net-news/liferea/Manifest1
-rw-r--r--net-news/liferea/liferea-1.12.8.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/net-news/liferea/Manifest b/net-news/liferea/Manifest
index c038565a1be3..908db198a480 100644
--- a/net-news/liferea/Manifest
+++ b/net-news/liferea/Manifest
@@ -1,2 +1,3 @@
DIST liferea-1.12.3.tar.bz2 1467804 BLAKE2B 3ef8039b7af136568e041309a384547543908e193cd384af819e24cd7ae213e4020e0ea099128295603ecf36d5d817b7529a2356191320ba80f4624128a72a36 SHA512 574dd13502fee81e81e88a0fa3a57028af2d2bfcfed5a132468a2be9257a886c7cbf958883c230deb6dbf952912ecc92631396ef6b5c353315833e0541db1208
DIST liferea-1.12.7.tar.bz2 1495627 BLAKE2B 36e95d270e3c3f68499073c7f2b1b6c987b67fc40517bfeb95c7ce02fc0c66daccb8e7d15709f1a047b36eea3d6d0cfe4af2e37f6809051f1be7613a36e0234f SHA512 7628f089940cd285ae6269b8d788b230572a0f5cab8a81ea1e92010de98a3ecd21d39596be6c18c055469579468fe3df7fca4e917a6a1ef3644a5e24c8e55109
+DIST liferea-1.12.8.tar.bz2 1496590 BLAKE2B 8b2f7298b58bd400a3daffc48c0f6b907cbcade054f08a57da7ca8f291fb9f2a86b9e2dbcacab58a43c3a0c19d05304f6d5fc0f77acd7cced51090bcf3a0e154 SHA512 46f70bed9b9ae1a6d578dbda3d3e7751b839bee91443c245cc83a17d89f3a1c59fe6346f0ee4e72103511404620fcd65733121527cb841ba0c2be2f4d182b51b
diff --git a/net-news/liferea/liferea-1.12.8.ebuild b/net-news/liferea/liferea-1.12.8.ebuild
new file mode 100644
index 000000000000..a3cde7bace86
--- /dev/null
+++ b/net-news/liferea/liferea-1.12.8.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit autotools gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="News Aggregator for RDF/RSS/CDF/Atom/Echo feeds"
+HOMEPAGE="https://lzone.de/liferea/"
+SRC_URI="https://github.com/lwindolf/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ dev-libs/json-glib
+ dev-libs/libpeas[gtk,python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ gnome-base/gsettings-desktop-schemas
+ net-libs/libsoup:2.4
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_prepare() {
+ xdg_src_prepare
+
+ sed -i -e 's#$(datadir)/appdata#$(datadir)/metainfo#g' \
+ Makefile.am || die
+ eautoreconf
+}
+
+src_compile() {
+ # Workaround crash in libwebkit2gtk-4.0.so
+ # https://bugs.gentoo.org/704594
+ WEBKIT_DISABLE_COMPOSITING_MODE=1 \
+ default
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ elog "Additional features can be enabled via"
+ elog "\tapp-crypt/libsecret[introspection] for Libsecret Support plugin"
+ elog "\tdev-python/pycairo and x11-libs/gdk-pixbuf[introspection] for Tray Icon (GNOME Classic) plugin"
+ elog "\tmedia-libs/gstreamer[introspection] for Media Player plugin"
+ elog "\tnet-misc/networkmanager for monitoring network status"
+ elog "\tx11-libs/libnotify[introspection] for Popup Notifications plugin"
+}