summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news')
-rw-r--r--net-news/blam/Manifest1
-rw-r--r--net-news/blam/blam-1.8.12.ebuild41
-rw-r--r--net-news/blam/blam-1.8.9.ebuild41
-rw-r--r--net-news/blam/files/blam-1.8.9-use-elif.patch17
4 files changed, 0 insertions, 100 deletions
diff --git a/net-news/blam/Manifest b/net-news/blam/Manifest
index 2e02a3d20135..5412b3dc171e 100644
--- a/net-news/blam/Manifest
+++ b/net-news/blam/Manifest
@@ -1,2 +1 @@
DIST blam-1.8.12.tar.xz 309492 SHA256 6294d13629cd0cabc50ed3a489682b50c2c61972d55d8209b59b2a8b434810ea SHA512 b364be33cd2335015da4b05f403bced713d96fc455c16ded598f8227b724ac3c0b864e0013e94d2e5dc1d7e1b5982b8df7e7dc9bddcc6f194408751df37b921a WHIRLPOOL 54588986b656e9407a1740fd22ae1ebbad58adf2f7ae4d375245b0da17e9d7eec9c78978f0dca590cff644f7e0418c8901f1692a1c0d673ad5a4b2b39f07680c
-DIST blam-1.8.9.tar.bz2 267277 SHA256 b54a84af4fbabdbe277119190e99e57c07fd8230d58399d9643bd668585285ba SHA512 43d6639bdd7b12e60d20f2e83cda5c4fe9adad3acc45b440c54ad97f4dbc0ffc653a6ffbed613788909be4c4ce6498424ea54b510e76d95eff38f6c180cd9406 WHIRLPOOL bfdbcc66787c827323ebcb206e423195b80b8fbcefdd8fd54aa1dfc0ce37da48af2c711152079965e57bbddf95378a53aaf16de25e843e9178d8179eb345af0d
diff --git a/net-news/blam/blam-1.8.12.ebuild b/net-news/blam/blam-1.8.12.ebuild
deleted file mode 100644
index 88a31095dfc0..000000000000
--- a/net-news/blam/blam-1.8.12.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-GCONF_DEBUG="no"
-
-inherit mono-env gnome2
-
-DESCRIPTION="A RSS aggregator written in C#"
-HOMEPAGE="https://git.gnome.org/browse/blam"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND="
- >=dev-lang/mono-2.6.0
- dev-dotnet/dbus-sharp-glib:1.0
- >=dev-dotnet/gtk-sharp-2.12.6
- >=dev-dotnet/glade-sharp-2.12.6
- >=dev-dotnet/gconf-sharp-2.8.2
- dev-dotnet/notify-sharp
- >=dev-dotnet/webkit-sharp-0.2
- >=gnome-base/libgnomeui-2.2
- >=gnome-base/gconf-2.4
-"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- virtual/pkgconfig
- >=dev-util/intltool-0.25
-"
-
-src_prepare() {
- # https://bugzilla.gnome.org/show_bug.cgi?id=702798
- sed -i -e 's/.png//' blam.desktop.in.in || die
- sed -i -e 's/Application;//' blam.desktop.in.in || die
-
- gnome2_src_prepare
-}
diff --git a/net-news/blam/blam-1.8.9.ebuild b/net-news/blam/blam-1.8.9.ebuild
deleted file mode 100644
index 18e4501ced8b..000000000000
--- a/net-news/blam/blam-1.8.9.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-inherit mono eutils
-
-DESCRIPTION="A RSS aggregator written in C#"
-HOMEPAGE="http://blam.relatitude.org/"
-SRC_URI="http://blam.relatitude.org/download/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE=""
-
-RDEPEND=">=dev-lang/mono-2
- >=dev-dotnet/gtk-sharp-2.12.6
- >=dev-dotnet/glade-sharp-2.12.6
- >=dev-dotnet/gnome-sharp-2.16.1
- >=dev-dotnet/gconf-sharp-2.8.2
- >=dev-dotnet/webkit-sharp-0.2
- >=gnome-base/libgnomeui-2.2
- >=gnome-base/gconf-2.4"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- virtual/pkgconfig
- >=dev-util/intltool-0.25"
-
-# Disable parallel builds
-MAKEOPTS="${MAKEOPTS} -j1"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-use-elif.patch"
-}
-
-src_install() {
- make DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog INSTALL NEWS README
- mono_multilib_comply
-}
diff --git a/net-news/blam/files/blam-1.8.9-use-elif.patch b/net-news/blam/files/blam-1.8.9-use-elif.patch
deleted file mode 100644
index 15a35fe44e9c..000000000000
--- a/net-news/blam/files/blam-1.8.9-use-elif.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Description: Use correct preprocessor directive to avoid FTBFS
-Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648547
-Author: Carlos Martín Nieto <carlos@cmartin.tk>
-
-Index: blam/src/Application.cs
-===================================================================
---- blam.orig/src/Application.cs 2011-08-01 16:06:44.000000000 +0200
-+++ blam/src/Application.cs 2011-08-01 16:07:17.000000000 +0200
-@@ -22,7 +22,7 @@
- #if DBUS_SHARP
- using DBus;
- using org.freedesktop.DBus;
--#elseif NDESK_DBUS
-+#elif NDESK_DBUS
- using NDesk.DBus;
- using org.freedesktop.DBus;
- #endif