summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nntp/sabnzbd/sabnzbd-1.0.3.ebuild')
-rw-r--r--net-nntp/sabnzbd/sabnzbd-1.0.3.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/net-nntp/sabnzbd/sabnzbd-1.0.3.ebuild b/net-nntp/sabnzbd/sabnzbd-1.0.3.ebuild
index 2df677f032c6..fd4a8a49d788 100644
--- a/net-nntp/sabnzbd/sabnzbd-1.0.3.ebuild
+++ b/net-nntp/sabnzbd/sabnzbd-1.0.3.ebuild
@@ -117,12 +117,16 @@ pkg_postinst() {
einfo "As growl isn't default notification system on gentoo we disable it."
einfo "By default notifications are forwarded to the 23053 port(gntp)."
- if [ "$(get_major_version ${REPLACING_VERSIONS})" == "0" ]; then
- echo
- ewarn "Upgrading from ${PN}-0.x.y to ${PN}-1.x.y introduces incompatible changes"
- ewarn "See http://wiki.sabnzbd.org/introducing-1-0-0."
- ewarn "In particular, you need to let your queue complete before restarting ${PN}"
- fi
+ local replacing
+ for replacing in ${REPLACING_VERSIONS}; do
+ if [ "$(get_major_version ${replacing})" == "0" ]; then
+ echo
+ ewarn "Upgrading from ${PN}-0.x.y to ${PN}-1.x.y introduces incompatible changes"
+ ewarn "See http://wiki.sabnzbd.org/introducing-1-0-0."
+ ewarn "In particular, you need to let your queue complete before restarting ${PN}"
+ break
+ fi
+ done
}
pkg_postrm() {