summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/pan/Manifest1
-rw-r--r--net-nntp/pan/pan-0.146.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-nntp/pan/Manifest b/net-nntp/pan/Manifest
index e75bf57877f9..220106490ae3 100644
--- a/net-nntp/pan/Manifest
+++ b/net-nntp/pan/Manifest
@@ -1 +1,2 @@
DIST pan-0.145.tar.bz2 2307162 BLAKE2B 09535013d8c2fb511b8c79ef185880b69a3f948d0e168b4fb8acc4d3d07d94fb756df171d003b12e1baef3201e2b8be22d583bb9ff551a5ae22f464feaa6f077 SHA512 3dc92d519158ddd480fc43250bf7a3ec67a877e58b0877c02b99f1dfd968bf18c9a20c3d8c4b6acab4132da89b6b91dd2992616ddf46c1c3f9aa0de8f8ee1949
+DIST pan-0.146.tar.bz2 2309326 BLAKE2B 327582ddcf293f4f5dbd15e30b2c604173b4b5a7c249f4d7cc4181d403b0b397257b017a6a0f65f5ad8da369da427b79e7e7de1aaca1a9af8613863380918148 SHA512 6eb2cdf60bb8cc36b53448edd90ccd3d17d7eb9a96958f6d549ee457578d63edfaababd838009be42e2787bdbac64893eb101170a7d394b05b4c4ee095975810
diff --git a/net-nntp/pan/pan-0.146.ebuild b/net-nntp/pan/pan-0.146.ebuild
new file mode 100644
index 000000000000..825f855de582
--- /dev/null
+++ b/net-nntp/pan/pan-0.146.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A newsreader for GNOME"
+HOMEPAGE="http://pan.rebelbase.com/"
+SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dbus gnome-keyring libnotify spell ssl"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ dev-libs/gmime:2.6
+ >=sys-libs/zlib-1.2.0
+ >=x11-libs/gtk+-2.16:2
+ gnome-keyring? ( >=gnome-base/libgnome-keyring-3.2 )
+ libnotify? ( >=x11-libs/libnotify-0.4.1:0= )
+ spell? (
+ >=app-text/enchant-1.6:0/0
+ >=app-text/gtkspell-2.0.7:2 )
+ ssl? ( >=net-libs/gnutls-3:0= )
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Wait for webkitgtk4 support
+ # gtk3 support is still not ready (follow what Fedora does)
+ # gmime:3.0 support claimed to be experimental still in 0.145, waiting with it until it's not experimental anymore or we work towards removing :2.6
+ gnome2_src_configure \
+ --with-yelp-tools \
+ --without-gtk3 \
+ --without-gmime30 \
+ --without-webkit \
+ $(use_with dbus) \
+ $(use_enable gnome-keyring gkr) \
+ $(use_with spell gtkspell) \
+ $(use_enable libnotify) \
+ $(use_with ssl gnutls)
+}