summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/cdsclient/cdsclient-3.8.1.ebuild')
-rw-r--r--sci-astronomy/cdsclient/cdsclient-3.8.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-astronomy/cdsclient/cdsclient-3.8.1.ebuild b/sci-astronomy/cdsclient/cdsclient-3.8.1.ebuild
new file mode 100644
index 000000000000..15584088baff
--- /dev/null
+++ b/sci-astronomy/cdsclient/cdsclient-3.8.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils versionator
+
+# upstream versioning wrong: 3.71 is really 3.7.1
+MYP="${PN}-$(delete_version_separator 2)"
+
+DESCRIPTION="Collection of scripts to access the CDS databases"
+HOMEPAGE="http://cdsweb.u-strasbg.fr/doc/cdsclient.html"
+SRC_URI="ftp://cdsarc.u-strasbg.fr/pub/sw/${MYP}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RESTRICT="mirror bindist"
+DEPEND=""
+RDEPEND="app-shells/tcsh"
+
+S="${WORKDIR}/${MYP}"
+
+PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
+src_prepare() {
+ default
+ # remove non standard "mantex" page
+ sed -e 's/aclient.tex//' -i configure || die
+}
+
+src_install() {
+ local bindir="${EPREFIX}/usr/bin/${PN}"
+ emake DESTDIR="${D}" SHSDIR="${D}${bindir}" install
+ cat <<-EOF > 99${PN}
+ PATH=${bindir}
+ ROOTPATH=${bindir}
+ EOF
+ doenvd 99${PN}
+}