summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/bioperl-db/bioperl-db-9999-r1.ebuild')
-rw-r--r--sci-biology/bioperl-db/bioperl-db-9999-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-biology/bioperl-db/bioperl-db-9999-r1.ebuild b/sci-biology/bioperl-db/bioperl-db-9999-r1.ebuild
new file mode 100644
index 000000000000..aad5b6e4abe5
--- /dev/null
+++ b/sci-biology/bioperl-db/bioperl-db-9999-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit perl-module git-2
+
+DESCRIPTION="Perl tools for bioinformatics - Perl API that accesses the BioSQL schema"
+HOMEPAGE="http://www.bioperl.org/"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/bioperl/${PN}.git
+ https://github.com/bioperl/${PN}.git"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+CDEPEND=">=sci-biology/bioperl-${PV}
+ dev-perl/DBI
+ sci-biology/biosql"
+DEPEND="dev-perl/Module-Build
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/BioPerl-db-${PV}"
+
+src_configure() {
+ # This disables tests. TODO: Enable tests
+ sed -i -e '/biosql_conf();/d' \
+ -e '/skip.*DBHarness.biosql.conf/d' "${S}/Build.PL" || die
+ perl-module_src_configure
+}
+
+src_install() {
+ mydoc="AUTHORS BUGS FAQ"
+ perl-module_src_install
+}