summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/cufflinks/files/cufflinks-1.3.0-autotools.patch')
-rw-r--r--sci-biology/cufflinks/files/cufflinks-1.3.0-autotools.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-biology/cufflinks/files/cufflinks-1.3.0-autotools.patch b/sci-biology/cufflinks/files/cufflinks-1.3.0-autotools.patch
new file mode 100644
index 000000000000..73e52b4343a0
--- /dev/null
+++ b/sci-biology/cufflinks/files/cufflinks-1.3.0-autotools.patch
@@ -0,0 +1,38 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -27,6 +27,7 @@ AC_PROG_AWK
+ AC_PROG_CXX
+ AC_PROG_CC
+ AC_PROG_MAKE_SET
++AM_PROG_AR
+ AC_PROG_RANLIB
+ AC_PROG_INSTALL
+ AM_PATH_PYTHON([2.4])
+@@ -54,7 +55,7 @@ AC_CANONICAL_HOST
+
+ # set CFLAGS and CXXFLAGS
+ user_CFLAGS=${CFLAGS}
+-generic_CFLAGS="-Wall -Wno-strict-aliasing -g -gdwarf-2 -Wuninitialized"
++generic_CFLAGS="-Wall -Wno-strict-aliasing -Wuninitialized"
+ ext_CFLAGS=""
+ debug_CFLAGS=""
+ #echo "${host_cpu}-${host_os}"
+@@ -99,15 +100,15 @@ AC_ARG_ENABLE(profiling, [ --enable-profiling enable profiling with
+ [ext_LDFLAGS="-lprofiler -ltcmalloc"], [])
+
+ CFLAGS="${generic_CFLAGS} ${ext_CFLAGS} ${user_CFLAGS} ${debug_CFLAGS} ${OPENMP_CFLAGS}"
+-CXXFLAGS="$CFLAGS"
++CXXFLAGS="$CXXFLAGS"
+ CXXFLAGS="$CXXFLAGS $BOOST_CPPFLAGS $BAM_CPPFLAGS"
+-LDFLAGS="$ext_LDFLAGS"
++LDFLAGS="$LDFLAGS $ext_LDFLAGS"
+
+ # Checks for structures/functions that can be used to determine system memory
+ AC_CHECK_MEMBERS([struct sysinfo.totalram], [], [], [#include <sys/sysinfo.h>])
+ AC_CHECK_DECLS([sysctl, CTL_HW, HW_PHYSMEM], [], [], [#include <sys/sysctl.h>])
+
+-AM_INIT_AUTOMAKE([-Wall -Werror tar-pax foreign])
++AM_INIT_AUTOMAKE([-Wall tar-pax foreign subdir-objects])
+
+ AC_CONFIG_FILES([Makefile
+ src/Makefile])