summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/prosite/prosite-19.36.ebuild')
-rw-r--r--sci-biology/prosite/prosite-19.36.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-biology/prosite/prosite-19.36.ebuild b/sci-biology/prosite/prosite-19.36.ebuild
new file mode 100644
index 000000000000..552c9193733f
--- /dev/null
+++ b/sci-biology/prosite/prosite-19.36.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="A protein families and domains database"
+LICENSE="swiss-prot"
+HOMEPAGE="http://ca.expasy.org/prosite"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="emboss? ( sci-biology/emboss )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ if use emboss; then
+ mkdir PROSITE
+ echo
+ einfo "Indexing PROSITE for usage with EMBOSS."
+ EMBOSS_DATA="." prosextract -auto -prositedir "${S}" || die \
+ "Indexing PROSITE failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins ${PN}.{doc,dat,lis} || die "Installing raw database failed."
+ fi
+ dodoc *.txt || die "Documentation installation failed."
+ dohtml *.htm || die "HTML documentation installation failed."
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/PROSITE
+ doins PROSITE/* || die "Installing EMBOSS data files failed."
+ fi
+}