summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/speedcrunch')
-rw-r--r--sci-calculators/speedcrunch/Manifest1
-rw-r--r--sci-calculators/speedcrunch/files/speedcrunch-0.10.1-iconname.patch11
-rw-r--r--sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild47
-rw-r--r--sci-calculators/speedcrunch/speedcrunch-0.11-r1.ebuild49
4 files changed, 0 insertions, 108 deletions
diff --git a/sci-calculators/speedcrunch/Manifest b/sci-calculators/speedcrunch/Manifest
index 62da5f46f12c..11ab180808ba 100644
--- a/sci-calculators/speedcrunch/Manifest
+++ b/sci-calculators/speedcrunch/Manifest
@@ -1,2 +1 @@
-DIST speedcrunch-0.10.1.tar.gz 1722124 SHA256 9d4e4ddd8bc6a60d59b9cb4815511ba20a5767719928eae3729e4df6c96dec84 SHA512 cafd2dc80d4925e0228648883e0117dfe8f7f80b715fc1a97586c19d4f5790833d422aacc117f5beafc18918c116004cb8fce5701b801280f1e9e74a5933d037 WHIRLPOOL b58527f0337fea4c1798802e9d16b1a26de563b963334c8215f06e0502836c1c6eeff590f66222780645050642904600fd44eaee490e86344506cc6cc45ff1cd
DIST speedcrunch-0.11.tar.gz 1516510 SHA256 3632f2b40ac628d2665c838643cc99c50e89b60f54ac2a82b4533d254f0cb6eb SHA512 19d7d5b80709063768abf7076a95e25b7c16956dd20ab181d3876b87bc26e7d8c18820a7ca23af22ea3b52d67de12238b7a106e575415ee755c8c204f732eaf1 WHIRLPOOL 14bca4dfc37e3d9c7fa1ae998a9b30831bf1d9b49ba6370ad38a545d56a37d7b0b7cfbc44040f605d1b95b3a373774d1ef5013eba9afc9a45e62d05f47ab1f30
diff --git a/sci-calculators/speedcrunch/files/speedcrunch-0.10.1-iconname.patch b/sci-calculators/speedcrunch/files/speedcrunch-0.10.1-iconname.patch
deleted file mode 100644
index 3e716e869114..000000000000
--- a/sci-calculators/speedcrunch/files/speedcrunch-0.10.1-iconname.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gui/aboutbox.cpp.orig 2008-11-17 20:12:32.000000000 +0000
-+++ src/gui/aboutbox.cpp 2008-11-17 20:12:50.000000000 +0000
-@@ -209,7 +209,7 @@
- infoLabel->setOpenExternalLinks( true );
-
- QLabel * iconLabel = new QLabel( this );
-- iconLabel->setPixmap( QPixmap( ":/crunch.png" ) );
-+ iconLabel->setPixmap( QPixmap( ":/speedcrunch.png" ) );
- iconLabel->setAlignment( Qt::AlignVCenter | Qt::AlignRight );
-
- MarqueeText * marqueeText = new MarqueeText( this );
diff --git a/sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild b/sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild
deleted file mode 100644
index 6db83dea83b5..000000000000
--- a/sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit eutils cmake-utils
-
-DESCRIPTION="A fast and usable calculator for power users"
-HOMEPAGE="https://code.google.com/p/speedcrunch/"
-SRC_URI="https://speedcrunch.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-DEPEND="dev-qt/qtgui:4"
-RDEPEND="${DEPEND}"
-
-LANGS="ca cs de en es es_AR eu fi fr he id it nb nl no pl
- pt pt_BR ro ru sv tr zh_CN"
-for lang in ${LANGS}; do
- IUSE="${IUSE} linguas_${lang}"
-done
-
-S="${WORKDIR}/${P}/src"
-
-src_prepare( ) {
- epatch "${FILESDIR}"/${P}-iconname.patch
- # regenerate translations
- lrelease speedcrunch.pro || die
- local lang
- for lang in ${LANGS}; do
- if ! use linguas_${lang}; then
- sed -i -e "s:i18n/${lang}\.qm::" Translations.cmake || die
- sed -i -e "s:books/${lang}::" CMakeLists.txt || die
- fi
- done
-}
-
-src_install() {
- cmake-utils_src_install
- cd ..
- dodoc ChangeLog ChangeLog.floatnum HACKING.txt LISEZMOI README TRANSLATORS
- use doc && dodoc doc/*.pdf
-}
diff --git a/sci-calculators/speedcrunch/speedcrunch-0.11-r1.ebuild b/sci-calculators/speedcrunch/speedcrunch-0.11-r1.ebuild
deleted file mode 100644
index 137bcb35f964..000000000000
--- a/sci-calculators/speedcrunch/speedcrunch-0.11-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PLOCALES="ca_ES cs_CZ de_DE en_GB en_US es_AR es_ES et_EE eu_ES fi_FI
- fr_FR he_IL hu_HU id_ID it_IT ja_JP ko_KR lv_LV nb_NO nl_NL pl_PL pt_BR
- pt_PT ro_RO ru_RU sv_SE vi_VN zh_CN"
-
-CMAKE_MAKEFILE_GENERATOR=ninja
-
-inherit cmake-utils l10n
-
-DESCRIPTION="Fast and usable calculator for power users"
-HOMEPAGE="http://speedcrunch.org/"
-SRC_URI="https://github.com/${PN}/SpeedCrunch/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-DEPEND="dev-qt/qtgui:4"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/SpeedCrunch-${PV}/src"
-
-src_prepare() {
- my_rm_loc() {
- rm "resources/locale/${1}.qm" || die
- sed -i resources/speedcrunch.qrc \
- -e "s|<file>locale/${1}.qm</file>||" || die
- sed -i gui/mainwindow.cpp \
- -e "s|map.insert(QString::fromUtf8(\".*, QLatin1String(\"${1}\"));||" || die
- }
-
- l10n_find_plocales_changes 'resources/locale' '' '.qm'
- l10n_for_each_disabled_locale_do my_rm_loc
-
- cmake-utils_src_prepare
-}
-
-src_install() {
- cmake-utils_src_install
- cd .. || die
- doicon -s scalable gfx/speedcrunch.svg
- use doc && dodoc doc/*.pdf
-}