summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/mosflm/files')
-rw-r--r--sci-chemistry/mosflm/files/7.0.6-Makefile.patch13
-rw-r--r--sci-chemistry/mosflm/files/7.0.6-impl-dec.patch36
-rw-r--r--sci-chemistry/mosflm/files/7.0.6-parallel.patch28
-rw-r--r--sci-chemistry/mosflm/files/7.0.7-parallel.patch92
-rw-r--r--sci-chemistry/mosflm/files/7.0.9-parallel.patch92
-rw-r--r--sci-chemistry/mosflm/files/mosflm-7.0.7-buffer-overflow.patch16
-rw-r--r--sci-chemistry/mosflm/files/mosflm-7.0.7-impl-dec.patch29
-rw-r--r--sci-chemistry/mosflm/files/mosflm-7.0.9-buffer-overflow.patch16
8 files changed, 0 insertions, 322 deletions
diff --git a/sci-chemistry/mosflm/files/7.0.6-Makefile.patch b/sci-chemistry/mosflm/files/7.0.6-Makefile.patch
deleted file mode 100644
index a35232f6e8c0..000000000000
--- a/sci-chemistry/mosflm/files/7.0.6-Makefile.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile 2008-10-17 16:15:30.000000000 +0200
-+++ Makefile.new 2009-02-20 21:52:34.000000000 +0100
-@@ -22,7 +22,7 @@
- CBFLIBS = cbf/lib/libcbf.a
- JPGLIBS = jpg/libjpeg.a
-
--all: $(DPSLIBS) $(CBFLIBS) $(JPGLIBS)
-- cd mosflm ; make
-+all: dpslibs cbflibs
-+ +make -C mosflm
-
- ##########################################################################
-
diff --git a/sci-chemistry/mosflm/files/7.0.6-impl-dec.patch b/sci-chemistry/mosflm/files/7.0.6-impl-dec.patch
deleted file mode 100644
index da393eb93fe6..000000000000
--- a/sci-chemistry/mosflm/files/7.0.6-impl-dec.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff --git a/mosflm/bravais_fortran.c b/mosflm/bravais_fortran.c
-index 3d68cad..800bd0e 100644
---- a/mosflm/bravais_fortran.c
-+++ b/mosflm/bravais_fortran.c
-@@ -2,6 +2,7 @@
- #include <stdlib.h>
- #include <math.h>
- #include "../util/util.h"
-+#include "../util/bravais.h"
-
- /* bravais_fortran_(): This routine converts array from FORTRAN program
- to structure for call to bravais
-diff --git a/mosflm/chelp.c b/mosflm/chelp.c
-index b2aaefc..fa44ab0 100644
---- a/mosflm/chelp.c
-+++ b/mosflm/chelp.c
-@@ -5,6 +5,7 @@
- /* modified for Linux by Joachim Meyer jmeyer@embl-heidelberg.de 1998.05.19 */
-
- #include "chelp.h"
-+#include <stdio.h>
-
- #if CALL_LIKE_HPUX
- void chelp ()
-diff --git a/mosflm/pck.c b/mosflm/pck.c
-index ec094fc..288671d 100644
---- a/mosflm/pck.c
-+++ b/mosflm/pck.c
-@@ -17,6 +17,7 @@
- #include <math.h>
- #include <ctype.h>
- #include <string.h>
-+#include <unistd.h>
-
- #define BYTE char
- #define WORD short int
diff --git a/sci-chemistry/mosflm/files/7.0.6-parallel.patch b/sci-chemistry/mosflm/files/7.0.6-parallel.patch
deleted file mode 100644
index f735c7ce5cf7..000000000000
--- a/sci-chemistry/mosflm/files/7.0.6-parallel.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- cbf/Makefile 2009-08-31 09:35:06.000000000 +0200
-+++ cbf/Makefile.new 2009-08-31 10:44:46.000000000 +0200
-@@ -362,6 +362,8 @@
- $(EXAMPLES)/img.h \
- $(INCLUDE)/md5.h
-
-+OBJ = $(subst .c,.o,$(SOURCE))
-+
- #
- # Compile the library and examples
- #
-@@ -379,11 +381,14 @@
- $(LIB):
- mkdir $(LIB)
-
-+
-+.c.o: $(SOURCE) $(HEADERS)
-+ $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $<
-+
- #
- # CBF library
- #
--$(LIB)/libcbf.a: $(SOURCE) $(HEADERS) $(COMMONDEP)
-- $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $(SOURCE)
-+$(LIB)/libcbf.a: $(OBJ) $(COMMONDEP)
- $(AR) cr $@ *.o
- rm *.o
- if [ -f $(RANLIB) ]; then $(RANLIB) $@ ; fi
diff --git a/sci-chemistry/mosflm/files/7.0.7-parallel.patch b/sci-chemistry/mosflm/files/7.0.7-parallel.patch
deleted file mode 100644
index df0a8b63273a..000000000000
--- a/sci-chemistry/mosflm/files/7.0.7-parallel.patch
+++ /dev/null
@@ -1,92 +0,0 @@
- Makefile | 21 ++++++++++-----------
- cbf/Makefile | 9 +++++++--
- 2 files changed, 17 insertions(+), 13 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 37f4c7e..51d4164 100644
---- a/Makefile
-+++ b/Makefile
-@@ -22,8 +22,8 @@ DPSLIBS = lib/DPSLIB.a
- CBFLIBS = cbf/lib/libcbf.a
- JPGLIBS = jpg/libjpeg.a
-
--all: $(DPSLIBS) $(CBFLIBS) $(JPGLIBS)
-- cd mosflm ; make
-+all: $(DPSLIBS)
-+ $(MAKE) -C mosflm
-
- ##########################################################################
- # #
-@@ -47,22 +47,21 @@ dpslibs:
-
- cbflibs:
- rm -f `find ./cbf -name "*.a" -print`
-- cd cbf ; make all ; if [ -f $(RANLIB) ]; \
-- then $(RANLIB) lib/libcbf.a; fi
-+ $(MAKE) -C cbf all
-
- jpglibs:
-- cd jpg ; if [ ! -f Makefile ]; then ./configure ; fi; make libjpeg.a
-+ cd jpg ; if [ ! -f Makefile ]; then ./configure ; fi; $(MAKE) libjpeg.a
-
- ${DPSLIBS}:
-- make dpslibs
-+ $(MAKE) dpslibs
-
- ${CBFLIBS}:
-- make cbflibs
-+ $(MAKE) cbflibs
-
- ${JPGLIBS}:
-- make jpglibs
-+ $(MAKE) jpglibs
-
--libs: ${DPSLIBS} ${CBFLIBS} ${JPGLIBS}
-+libs: ${DPSLIBS} ${CBFLIBS}
- @echo "****************************************************************"
- @echo " Making libraries for system ${HOSTTYPE}"
- @echo "****************************************************************"
-@@ -71,11 +70,11 @@ ipmosflm: libs
- @echo "****************************************************************"
- @echo " Making IPMOSFLM for system ${HOSTTYPE}"
- @echo "****************************************************************"
-- cd mosflm ; make ipmosflm
-+ $(MAKE) -C mosflm ipmosflm
-
- force:
- rm bin/ipmosflm
-- make ipmosflm
-+ $(MAKE) ipmosflm
-
- install:
- @echo "the executable is in ${MOSHOME}/bin/ipmosflm"
-diff --git a/cbf/Makefile b/cbf/Makefile
-index e61497c..c3c94ac 100644
---- a/cbf/Makefile
-+++ b/cbf/Makefile
-@@ -362,6 +362,8 @@ HEADERS = $(INCLUDE)/cbf.h \
- $(EXAMPLES)/img.h \
- $(INCLUDE)/md5.h
-
-+OBJ = $(subst .c,.o,$(SOURCE))
-+
- #
- # Compile the library and examples
- #
-@@ -379,11 +381,14 @@ $(INSTALLDIR):
- $(LIB):
- mkdir $(LIB)
-
-+
-+.c.o: $(SOURCE) $(HEADERS)
-+ $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $<
-+
- #
- # CBF library
- #
--$(LIB)/libcbf.a: $(SOURCE) $(HEADERS) $(COMMONDEP)
-- $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $(SOURCE)
-+$(LIB)/libcbf.a: $(OBJ) $(COMMONDEP)
- $(AR) cr $@ *.o
- rm *.o
- if [ -f $(RANLIB) ]; then $(RANLIB) $@ ; fi
diff --git a/sci-chemistry/mosflm/files/7.0.9-parallel.patch b/sci-chemistry/mosflm/files/7.0.9-parallel.patch
deleted file mode 100644
index 38c6fc45a5c0..000000000000
--- a/sci-chemistry/mosflm/files/7.0.9-parallel.patch
+++ /dev/null
@@ -1,92 +0,0 @@
- Makefile | 21 ++++++++++-----------
- cbf/Makefile | 9 +++++++--
- 2 files changed, 17 insertions(+), 13 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 3d2f543..2219d8d 100644
---- a/Makefile
-+++ b/Makefile
-@@ -22,8 +22,8 @@ DPSLIBS = lib/DPSLIB.a
- CBFLIBS = cbf/lib/libcbf.a
- JPGLIBS = jpg/libjpeg.a
-
--all: $(DPSLIBS) $(CBFLIBS) $(JPGLIBS)
-- cd mosflm ; make
-+all: $(DPSLIBS)
-+ $(MAKE) -C mosflm
-
- dpslibs:
- @-find . -name "*a" -delete
-@@ -32,22 +32,21 @@ dpslibs:
-
- cbflibs:
- @-find ./cbf -name "*.a" -delete
-- cd cbf ; make all ; if [ -f $(RANLIB) ]; \
-- then $(RANLIB) lib/libcbf.a; fi
-+ $(MAKE) -C cbf all
-
- jpglibs:
-- cd jpg ; if [ ! -f Makefile ]; then ./configure ; fi; make libjpeg.a
-+ cd jpg ; if [ ! -f Makefile ]; then ./configure ; fi; $(MAKE) libjpeg.a
-
- ${DPSLIBS}:
-- make dpslibs
-+ $(MAKE) dpslibs
-
- ${CBFLIBS}:
-- make cbflibs
-+ $(MAKE) cbflibs
-
- ${JPGLIBS}:
-- make jpglibs
-+ $(MAKE) jpglibs
-
--libs: ${DPSLIBS} ${CBFLIBS} ${JPGLIBS}
-+libs: ${DPSLIBS} ${CBFLIBS}
- @echo "****************************************************************"
- @echo " Making libraries for system ${HOSTTYPE}"
- @echo "****************************************************************"
-@@ -56,11 +55,11 @@ ipmosflm: libs
- @echo "****************************************************************"
- @echo " Making IPMOSFLM for system ${HOSTTYPE}"
- @echo "****************************************************************"
-- cd mosflm ; make ipmosflm
-+ $(MAKE) -C mosflm ipmosflm
-
- force:
- @-rm -f bin/ipmosflm
-- make ipmosflm
-+ $(MAKE) ipmosflm
-
- install:
- @echo "the executable is in ${MOSHOME}/bin/ipmosflm"
-diff --git a/cbf/Makefile b/cbf/Makefile
-index e61497c..c3c94ac 100644
---- a/cbf/Makefile
-+++ b/cbf/Makefile
-@@ -362,6 +362,8 @@ HEADERS = $(INCLUDE)/cbf.h \
- $(EXAMPLES)/img.h \
- $(INCLUDE)/md5.h
-
-+OBJ = $(subst .c,.o,$(SOURCE))
-+
- #
- # Compile the library and examples
- #
-@@ -379,11 +381,14 @@ $(INSTALLDIR):
- $(LIB):
- mkdir $(LIB)
-
-+
-+.c.o: $(SOURCE) $(HEADERS)
-+ $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $<
-+
- #
- # CBF library
- #
--$(LIB)/libcbf.a: $(SOURCE) $(HEADERS) $(COMMONDEP)
-- $(CC) $(CFLAGS) $(INCLUDES) $(WARNINGS) -c $(SOURCE)
-+$(LIB)/libcbf.a: $(OBJ) $(COMMONDEP)
- $(AR) cr $@ *.o
- rm *.o
- if [ -f $(RANLIB) ]; then $(RANLIB) $@ ; fi
diff --git a/sci-chemistry/mosflm/files/mosflm-7.0.7-buffer-overflow.patch b/sci-chemistry/mosflm/files/mosflm-7.0.7-buffer-overflow.patch
deleted file mode 100644
index 90158eb458d5..000000000000
--- a/sci-chemistry/mosflm/files/mosflm-7.0.7-buffer-overflow.patch
+++ /dev/null
@@ -1,16 +0,0 @@
- mosflm/pilatus_c.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/mosflm/pilatus_c.c b/mosflm/pilatus_c.c
-index 1eaae26..cce5a02 100644
---- a/mosflm/pilatus_c.c
-+++ b/mosflm/pilatus_c.c
-@@ -34,7 +34,7 @@ delete them later */
- int cbf_int[16];
- long cbf_int4[16];
- double cbf_double[16];
-- char cbf_char[16][24];
-+ char cbf_char[16][32];
- /* temporary from cbfwrap.c - pilatus doesn't have these, so we'll
- delete them later */
- int id, index, iindex;
diff --git a/sci-chemistry/mosflm/files/mosflm-7.0.7-impl-dec.patch b/sci-chemistry/mosflm/files/mosflm-7.0.7-impl-dec.patch
deleted file mode 100644
index 32f251f8e00c..000000000000
--- a/sci-chemistry/mosflm/files/mosflm-7.0.7-impl-dec.patch
+++ /dev/null
@@ -1,29 +0,0 @@
- mosflm/mosflm_jpeg.c | 1 +
- src/dps/index/ind_gen_direct.c | 2 ++
- 2 files changed, 3 insertions(+), 0 deletions(-)
-
-diff --git a/mosflm/mosflm_jpeg.c b/mosflm/mosflm_jpeg.c
-index 2b32b2e..54684d0 100644
---- a/mosflm/mosflm_jpeg.c
-+++ b/mosflm/mosflm_jpeg.c
-@@ -76,6 +76,7 @@ G. Winter
- #include <fcntl.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#include <string.h>
- #if (defined _MSC_VER)
- /* no need to do this for __MINGW_ (Mingw gcc) this is just about unique!*/
- #define S_IRWXU S_IREAD|S_IWRITE|S_IEXEC
-diff --git a/src/dps/index/ind_gen_direct.c b/src/dps/index/ind_gen_direct.c
-index 6e143df..2eea61b 100644
---- a/src/dps/index/ind_gen_direct.c
-+++ b/src/dps/index/ind_gen_direct.c
-@@ -41,6 +41,8 @@
- /* #include <malloc.h> */
- #include "util.h"
- #include "ind_gen_direct.h"
-+#include "ind_help.h"
-+#include "ind_sort_merge.h"
- /* char *strcat( char *, const char *); */
-
-
diff --git a/sci-chemistry/mosflm/files/mosflm-7.0.9-buffer-overflow.patch b/sci-chemistry/mosflm/files/mosflm-7.0.9-buffer-overflow.patch
deleted file mode 100644
index bb4a16bf30fc..000000000000
--- a/sci-chemistry/mosflm/files/mosflm-7.0.9-buffer-overflow.patch
+++ /dev/null
@@ -1,16 +0,0 @@
- mosflm/pilatus_c.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/mosflm/pilatus_c.c b/mosflm/pilatus_c.c
-index 4a85b26..9893e0c 100644
---- a/mosflm/pilatus_c.c
-+++ b/mosflm/pilatus_c.c
-@@ -34,7 +34,7 @@ delete them later */
- int cbf_int[16] = {0};
- long cbf_int4[16] = {0};
- double cbf_double[16] = {0};
-- char cbf_char[16][24] = {' '};
-+ char cbf_char[16][32] = {' '};
- /* temporary from cbfwrap.c - pilatus doesn't have these, so we'll
- delete them later */
- int id, index, iindex;