summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/fricas/fricas-1.3.3.ebuild')
-rw-r--r--sci-mathematics/fricas/fricas-1.3.3.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sci-mathematics/fricas/fricas-1.3.3.ebuild b/sci-mathematics/fricas/fricas-1.3.3.ebuild
index 1be321f3f7bd..b844cb78f7b6 100644
--- a/sci-mathematics/fricas/fricas-1.3.3.ebuild
+++ b/sci-mathematics/fricas/fricas-1.3.3.ebuild
@@ -51,7 +51,7 @@ DEPEND="${RDEPEND}"
RESTRICT="strip"
src_configure() {
- local LISP n
+ local LISP n GMP
LISP=sbcl
n=${#LISPS[*]}
for ((n--; n > 0; n--)); do
@@ -64,8 +64,14 @@ src_configure() {
done
einfo "Using lisp: ${LISP}"
+ # bug #650788
+ if [[ ${LISP} = sbcl || ${LISP} = ccl ]]
+ then GMP=$(use_with gmp)
+ else GMP=''
+ fi
+
# aldor is not yet in portage
- econf --disable-aldor --with-lisp=${LISP} $(use_with X x) $(use_with gmp)
+ econf --disable-aldor --with-lisp=${LISP} $(use_with X x) ${GMP}
}
src_compile() {