summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/gr/gr-0.50.0.ebuild')
-rw-r--r--sci-visualization/gr/gr-0.50.0.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/sci-visualization/gr/gr-0.50.0.ebuild b/sci-visualization/gr/gr-0.50.0.ebuild
new file mode 100644
index 000000000000..71d7cb7c9312
--- /dev/null
+++ b/sci-visualization/gr/gr-0.50.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Universal framework for cross-platform visualization applications"
+HOMEPAGE="http://gr-framework.org/"
+SRC_URI="https://github.com/sciapp/gr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cairo ffmpeg opengl postscript qt5 tiff truetype X"
+
+DEPEND="
+ media-libs/fontconfig
+ media-libs/libjpeg-turbo
+ media-libs/libpng
+ media-libs/qhull
+ sys-libs/zlib
+ cairo? ( x11-libs/cairo )
+ ffmpeg? ( media-video/ffmpeg )
+ opengl? (
+ media-libs/glfw
+ virtual/opengl
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ qt5? ( dev-qt/qtgui:5 )
+ tiff? ( media-libs/tiff )
+ truetype? ( media-libs/freetype )
+ X? ( x11-libs/libX11 )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ use cairo || mycmakeargs+=( -DCAIRO_LIBRARY= )
+ use opengl || mycmakeargs+=( -DGLFW_LIBRARY= )
+ use postscript || mycmakeargs+=( -DGS_LIBRARY= )
+ use ffmpeg || mycmakeargs+=( -DFFMPEG_INCLUDE_DIR= )
+ use truetype || mycmakeargs+=( -DFREETYPE_LIBRARY= )
+ use tiff || mycmakeargs+=( -DTIFF_LIBRARY= )
+
+ # todo: Qt5, X11 automagic
+
+ mycmakeargs+=( -DCMAKE_INSTALL_PREFIX=/usr/gr )
+ #
+ # I need to have a serious conversation with upstream.
+ # * The main consumer of this package is dev-lang/julia.
+ # * If I patch gr to install in standard locations, julia does
+ # not find it anymore.
+ # * I can't patch julia, since the corresponding scripts are
+ # downloaded at runtime from its package registry ...
+ #
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ find "${ED}" -name '*.a' -delete
+
+ echo "GRDIR=/usr/gr" > "${T}/99gr"
+ echo "LDPATH=/usr/gr/$(get_libdir)" >> "${T}/99gr"
+ doenvd "${T}/99gr"
+
+ dosym ../gr/bin/gksqt /usr/bin/gksqt
+}