summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sec-policy')
-rw-r--r--sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild b/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild
index 21b98bd9ba70..062dec634f2c 100644
--- a/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild
+++ b/sec-policy/selinux-base-policy/selinux-base-policy-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
@@ -20,9 +20,9 @@ fi
HOMEPAGE="https://www.gentoo.org/proj/en/hardened/selinux/"
DESCRIPTION="SELinux policy for core modules"
-IUSE="+unconfined"
+IUSE="systemd +unconfined"
-RDEPEND="=sec-policy/selinux-base-${PVR}"
+RDEPEND="=sec-policy/selinux-base-${PVR}[systemd?]"
PDEPEND="unconfined? ( sec-policy/selinux-unconfined )"
DEPEND=""
@@ -35,6 +35,12 @@ S="${WORKDIR}/"
# itself), when reworked reinclude it. Only postinstall (where -b base.pp is
# added) needs to remain then.
+pkg_setup() {
+ if use systemd; then
+ MODS="${MODS} systemd"
+ fi
+}
+
pkg_pretend() {
for i in ${POLICY_TYPES}; do
if [[ "${i}" == "targeted" ]] && ! use unconfined; then