summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/daemonize/daemonize-1.7.8.ebuild')
-rw-r--r--sys-apps/daemonize/daemonize-1.7.8.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-apps/daemonize/daemonize-1.7.8.ebuild b/sys-apps/daemonize/daemonize-1.7.8.ebuild
new file mode 100644
index 000000000000..16382e7c34eb
--- /dev/null
+++ b/sys-apps/daemonize/daemonize-1.7.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Runs a command as a Unix daemon"
+HOMEPAGE="https://bmc.github.com/daemonize/"
+SRC_URI="https://github.com/bmc/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DOCS=( CHANGELOG.md README.md )
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's:\($(CC)\) $(CFLAGS) \(.*\.o\):\1 $(LDFLAGS) \2:' \
+ Makefile.in || die
+}