summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/fbset/fbset-2.1.ebuild')
-rw-r--r--sys-apps/fbset/fbset-2.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/fbset/fbset-2.1.ebuild b/sys-apps/fbset/fbset-2.1.ebuild
new file mode 100644
index 000000000000..a4244f2bde06
--- /dev/null
+++ b/sys-apps/fbset/fbset-2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="A utility to set the framebuffer videomode"
+HOMEPAGE="http://users.telenet.be/geertu/Linux/fbdev/"
+SRC_URI="http://users.telenet.be/geertu/Linux/fbdev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
+IUSE="static"
+
+DEPEND="sys-devel/bison
+ sys-devel/flex"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-build.patch"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin fbset modeline2fb || die "dobin failed"
+ doman *.[58]
+ dodoc etc/fb.modes.* INSTALL
+}