summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ibm-powerpc-utils/ibm-powerpc-utils-1.3.5-r1.ebuild')
-rw-r--r--sys-apps/ibm-powerpc-utils/ibm-powerpc-utils-1.3.5-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/ibm-powerpc-utils/ibm-powerpc-utils-1.3.5-r1.ebuild b/sys-apps/ibm-powerpc-utils/ibm-powerpc-utils-1.3.5-r1.ebuild
new file mode 100644
index 000000000000..6d7d066eea71
--- /dev/null
+++ b/sys-apps/ibm-powerpc-utils/ibm-powerpc-utils-1.3.5-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="Utilities for the maintainance of the IBM and Apple PowerPC platforms"
+HOMEPAGE="https://github.com/ibm-power-utilities/powerpc-utils"
+SRC_URI="https://github.com/ibm-power-utilities/${PN//ibm-}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="+rtas"
+
+S="${WORKDIR}/${P//ibm-}"
+
+SLOT="0"
+LICENSE="IBM"
+KEYWORDS="~ppc ~ppc64"
+
+DEPEND="
+ sys-devel/bc
+"
+RDEPEND="
+ !sys-apps/powerpc-utils
+ ${DEPEND}
+ rtas? ( >=sys-libs/librtas-2.0.2 )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.5-docdir.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with rtas librtas)
+}