summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.56.ebuild')
-rw-r--r--sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.56.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.56.ebuild b/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.56.ebuild
new file mode 100644
index 000000000000..53a3150b0cc8
--- /dev/null
+++ b/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.56.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Script to rescan the SCSI bus without rebooting"
+HOMEPAGE="http://www.garloff.de/kurt/linux/"
+SCRIPT_NAME="${PN}.sh"
+SRC_NAME="${SCRIPT_NAME}-${PV}"
+SRC_URI="http://www.garloff.de/kurt/linux/${SRC_NAME}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=sys-apps/sg3_utils-1.24
+ virtual/modutils
+ app-shells/bash"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ einfo "Unpacking into ${WORKDIR}/"
+ cp -f "${DISTDIR}"/${SRC_NAME} "${WORKDIR}"/${SCRIPT_NAME}
+ #epatch "${FILESDIR}"/${P}-support-sysfs-only-systems.patch
+}
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ into /usr
+ dosbin ${SCRIPT_NAME}
+ # Some scripts look for this without the trailing .sh
+ # Some look for it with the trailing .sh, so have a symlink
+ dosym ${SCRIPT_NAME} /usr/sbin/${PN}
+}