summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/toybox/toybox-0.4.9.ebuild')
-rw-r--r--sys-apps/toybox/toybox-0.4.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/toybox/toybox-0.4.9.ebuild b/sys-apps/toybox/toybox-0.4.9.ebuild
new file mode 100644
index 000000000000..133b749a36af
--- /dev/null
+++ b/sys-apps/toybox/toybox-0.4.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+# makefile is stupid
+RESTRICT="test"
+
+DESCRIPTION="Common linux commands in a multicall binary"
+HOMEPAGE="http://landley.net/code/toybox/"
+SRC_URI="http://landley.net/code/toybox/downloads/${P}.tar.bz2"
+
+# The source code does not explicitly say that it's BSD, but the author has repeatedly said it
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+src_configure() {
+ make defconfig
+}
+
+src_compile() {
+ emake toybox_unstripped
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ mkdir -p "${D}/usr/bin"
+ cp toybox "${D}/usr/bin" || die
+}